1

I have a polygon layer with one object. It is a flood inundation map. I could see my layer all the time in every scale factor. From one moment to the other it changed and know it is only visible if i zoom out and the whole polygon is visible. If i zoom in and only a part of the polygon should be visible, there is nothing. What can I do? I tried everything with layer properties -> general ->scale dependent visibility, but even if i uncheck it, the Layer is not visible.

1

Check if the shapefile's spatial index is stale or corrupt. Based on this technical article from ESRI, the shapefile's spatial index maybe corrupted. The technical article offers a solution that may help you solve the problem. Please have a look at it.

Another option is to try to export your data to a new shapefile, and see if that solve your problem.

  • Thank you for your help, but it didn't work. I have the folowing fileendings for my shapefile: *.dfb; *.prj; *.qix; *.qpj; *.shp; *.shx. In the article you mentioned the deleted the files with SBX and SBN extensions. I don t have them. But i tried to start with only the three obligated files (shp; dbf; shx) but i had stil the same problem. The second option you mentioned i tried as well but no sucess. – Isi May 17 '16 at 11:58
  • Try to load your data into new QGIS project and check if the problem still exist. – ahmadhanb May 17 '16 at 12:09
  • Yes i tried and also with another version of Qgis. Stil the same problem – Isi May 17 '16 at 12:23
  • @Isi - Perhaps you can upload your shapefile to a public server so that others could test it? – Joseph May 17 '16 at 12:48
  • I have not the permission to do that. – Isi May 17 '16 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.