1

In arcGIS 10, I have several raster maps, that I would like to clip according to a polygon feature (top map). I have tried the Clip function under Raster Processing<-Raster<-Data Management Tools, and ticked off the Maintain Clipping Extent box. I am not allowed to tick off the Use Input Features for Clipping Geometry box. But I end up with a map of the same extent but different shape than my polygon (bottom map). I really need the map to have the same extent and size of the polygon. I have tried un-ticking the Maintain clipping Extent box, but it makes no difference with regards to the result. I have added a picture of what I entered in the Clip box, and what the process looked like after the maps.

The polygon map. All my raster maps should have the same shape as this polygon

The result of the clip analysis of a raster map using the polygon as Output extent. the map has been limited to the extent of the polygon (it was worldwide before, but it does not have the shape of the polygon

enter image description here enter image description here

  • 1
    Please edit the question to contain the exact geoprocessing command which was issued. The default behavior is documented to use the envelope of the feature class, not the geometry, so the exact parameters are necessary. – Vince May 17 '16 at 15:02
  • I have tried updating my question, but am not quiet sure of what information you would like me to include. I did not use the command directly from the Geoprocessing menu, but used the Clip tool under Data management, Raster, Raster Processing. If more information is needed please let me know – LHAndersen May 17 '16 at 15:19
  • 1
    Every geoprocessing task is logged. You can review the command from the Results page. – Vince May 17 '16 at 15:41
  • Alternatively a picture of what you entered on the tool dialog can often show the parameter values used. – PolyGeo May 17 '16 at 18:25
  • Have you tried using the Extract by Mask feature in the Spatial Analyst toolbox? It usually works for this type of work. – Mikkel Lydholm Rasmussen May 18 '16 at 14:02
3

Try to dissolve the polygons and create only one polygon and use that as a clip polygon. But make sure the projection for both the raster and polygon shapefile is same. Different projections will not give you the desired result. Because if the projections of input polygon and raster are different, the clip based on feature extent will not be activated.

If dissolve didn't solve the problem to get one polygon (the outline polygon), try to make a copy of the input polygon shapefile, then click on start editing of the new copied shapefile and select all polygons then merge them all to get only one polygon (the outline polygon). Then follow the above process.

1

As a previous answer stated, I would make sure that both data sets are in the same projection. Another setting to look at would be under the "Environment settings" >> Raster Analysis. You can set your mask here to your clipping layer. You could also look at Processing Extent but that requires another raster as input.

A final solution I would try would be to convert your polygon to a raster and then try clipping again with the above environment settings.

See similar thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.