3

I am getting a strange error message when running the GRASS r.reclass algorithm. The error states that:

"The following layers were not correctly generated *reclassified You can check the log message to find more information about the execution of the algorithm. "

After having read the log-file a couple of times, I am none the wiser.

All that I found were a couple of error messages... "illegal latitude for north" "Invalid input" "Raster map not found"

If any of you have any idea what the reason is why the algorithm is not functioning correctly, please...let me know. See below for screenshots of log-file and re-class file. r.reclass input parameters

r.reclass log file

reclass text file

error log after using NEW input parameters. still no succes

New screen shots. I ran the r.reclass algorithm using different input parameters, but to no avail. (xmin,xmax,ymin,ymax = -180,179,-64,90)

2

The error report tell you that that you have entered illegal parameters. enter image description here

The values cant be over +/-180 for X and +/-90 for Y In the tool box, try setting the xmin and ymax to -180 and 90 respectively.

Since the GRASS tool takes these attributes from the layers, it might hint that there might be an underlying error with the source layer's CRS or extents.

  • Thanks for helping. Sadly, it didn't work. I thought it couldn't be the x/y boundaries, because (like you said) these values are given by the layer itself. I entered new input parameters for xmin,xmax,ymin,ymax, but to no avail. See new screenshot I uploaded for details of error log – J.A.Cado May 18 '16 at 9:55
  • What are the extents of the original layer? – HDunn May 18 '16 at 9:57
  • As seen in the first error log message: -180.0013888888888971,-64.9986111111111171 179.9986111111111029,90.0013888888888829 – J.A.Cado May 18 '16 at 11:14
  • I have no idea what the issue might be...? I think the only way to get the layer I want is to use a different reclass algorithm in QGIS. I saw there is a "SAGA - Reclassify Grid Values" algorithm. I'll try and see if this works – J.A.Cado May 23 '16 at 7:52
  • Ok...After having tried an extensive amount of different solutions, I have come to a very important conclusions: Always make sure you load the graph you want to reclass, in it's own CRS and have the same CRS active in QGIS. In the reclass function, you have to enter the coordinates of the frame within which you want the reclass to take place. If you load the map in QGIS with a different CRS, it is indeed possible that you go out of bounds, and get an error message as I got. – J.A.Cado Jun 1 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.