2

I'm trying to export a map as raster (GeoTIFF with world file) from print composer. The world file is always coming with Map units because I'm using Google Satellite from OpenLayers web plugin. I tried to change the CRS from Projected coordinate (EPSG:900913) to Geographic coordinate (edited : WGS84 EPSG:4326) in order to get lat/lng in the world file and the world file come as expected. But after changing to EPSG:4326 the position of some features were not correct. So I assume the transformation I'm doing is wrong.

The objective is to use Google basemap, add my layers and labels, then save everything as GeoTIFF to be used in other software. but that software is accepting only GeoTIFF with lat/long info in the world file not projections as map units.

Is there other way to do this conversion?

  • I think that here you will find an answer. gis.stackexchange.com/a/168167/50650 – Jost Hobic May 19 '16 at 8:59
  • 1
    EPSG: 3857 is also a projected CRS. in fact, it replaced EPSG:GOOGLE(900913). EPSG:4326 is a Geographic CRS with units in degrees. – HDunn May 19 '16 at 9:10
  • I have noticed this issue in the past with Bing maps, the Bing image tends to shift around at different zoom levels as well. – Matt May 19 '16 at 9:22
  • Sorry , you are right , I guess I used WGS84 EPSG:4326, the 3857 is also projected. – Mohsen May 19 '16 at 10:34
  • I checked the other post, but for me the projected map looks fine in both main window and print coposer. it's only when I change the CRS that the map in the main window get shifted. Is there a way to change from EPSG:900913 to WGS84 EPSG:4326 and still have everything in same place. OTF is enabled so normally all other layers should be translated properly and proportionally ! – Mohsen May 19 '16 at 10:36
1

I believe the key problem is as you mentioned in your question, that you use OpenLayers plugin.

There are two simple ways how to overcome forced CRS (EPSG 3857) by OpenLayers plugin:

  1. Convert OpenLayers layer into georeferenced image

    • In the map window load Google Satelite (or any other) map
    • Turn off all other layers
    • Save map as image (Project - Save as image...)
    • Load image and change project CRS to desired lat - long
  2. Use a different plugin called QuickMapServices, which

    • After installation of the plugin you must go to settings, and get contributed pack on contributed services tab to have also Google, Bing etc, services
    • This plugin transforms on-the-fly to whatever the project CRS is and does not change it
  • Thank you for the suggestions, I'm trying now the second option, didn't know about the QuickMapServices plugin :) , I've downloaded other maps from the contributed services and seems the map is fine with OTF enabled, will try in composer as well . I guess it should work. thanks a lot again for the help. – Mohsen May 20 '16 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.