2

I am not able to find the Raster Calculator in my process toolbox anymore, even though I worked with the Raster Calculator through the toolbox in the same version of QGIS (2.8) one month ago.

It wouldn't matter much because I still can run the raster calculator in the raster menu, However I have a problem in the Graphical Modeler because I need to use this algorithm and it is not available in the GDAL/OGR group.

Any ideas?

2

Have you tried to search of Raster Calculator in the processing toolbox? It should be under GDAL -> Miscellaneous. Also under SAGA -> Grid - Calculus. Make sure you select the advanced interface.

enter image description here

  • Of course, that was de way I used to find the Raster Calculator. I allways have found it in Miscellanius inside GDAL/OGR group. Now I just find the SAGA one, but it not have the same interface. Could be the updated of Processing Plugin? – Natalia Bernal May 20 '16 at 8:21
  • Actually, I have both QGIS 2.8.9 and 2.14.2, and I have raster calculator in both Miscellaneous and SAGA. I normally download QGIS from OSGeo4W. That is why, I did not face this issue. Also, the processing plugin that I have is up to date. – ahmadhanb May 20 '16 at 8:30
  • Try to update your QGIS to 2.8.9 LTR which is more stable from OSGeo4W, and check if the update can solve the issue that you have. – ahmadhanb May 20 '16 at 8:40
  • Thank you very much¡¡¡¡. I have reinstalled the GDAL/OGR libraries and command through the OSGeo4W Installer in web and now the Raster Calculator appears again¡¡¡. – Natalia Bernal May 20 '16 at 9:00
1

Have a look under Processing > Options if GDAL/OGR is activated. enter image description here

Which version of Processing do you have installed? It should be at 2.12.2 now I think...

  • Thanks for your quick answers¡¡¡. GDAL/OGR is active in Processing Options. The version of Processing I have installed it is 2.10.3, but it is said in the plugin interface that this is the version available in the Qgis repository. I dont Know, maybe the spanish version I have? – Natalia Bernal May 20 '16 at 8:37
  • The language version should not matter. Check in the plugin settings whether you are getting the plugins for version 2.14. My guess is that you are getting plugins for version 2.8 in your 2.14 install since both installs are on the same system, no? – valo May 20 '16 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.