1

I've upgraded QGIS to version 2.12.x (I tried both 2.12.2 and 2.12.4 versions) on Windows 7 x86-64.

QGIS crashes with the message 'minidump written to C:..." each time I try to load a .qgs file which has been created with a previous version. However, there is no problem when I launch qgis-browser without opening the file.

The problem doesn't seem to come from the newer version, nor from the .qgis file because :

  • the .qgis file can be opened from an other computer running the version 2.12.2,

  • the .qgis file can be opened on the same computer but with an other Windows user account.

This led me to search the problem in my Windows user profile. I tried to backup then remove all folders related to qgis in my user profile (.qgis, .qgis2, .matplotlib, .designer), but this has not solved the problem :(

Is it possible that problem stems from my user registry ?

Assuming yes, what is the better way to solve it ? Should I backup my NTUSER.DAT hive and then clean my user registry ?

Assuming yes, are there other keys than "HKEY_CURRENT_USERS\Software\QGIS" to delete ?

1

Before cleaning the registry, you can try switching from QGIS standalone to OSGEO4W Network installer. Both install separately.

Or unistall QGIS before reinstalling.

1
  • Thanks for your help. The problem concern a corporate computer. I can suggest an updgrade or a downgrade of the software, but I can't replace it by an other software. I already tried to downgrade to the previously installed version (2.8.X) and to uninstall then reinstall the 2.12.x version. But neither downgrading nor reinstalling the software have solved the problem. Thibault – tvataire May 24 '16 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.