2

I am trying to enable an enterprise database. I right click > enable and then navigate to our organizations keycode file. I get this error: Attribute Column Not found... (see screenshot)

error message from esri

This process has worked in the past but maybe IT has tweaked things or since 10.4 install this may have also changed things?

specs:

ArcGIS 10.4 (Advanced License) SQL Server 2008 Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64)

  • 1
    The important part of the error message didn't make it into the question: "Fail to enable database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT" See the third bullet in Whats New: Geodata – Vince May 24 '16 at 17:18
9

A google on "ArcGIS READ_COMMITTED_SNAPSHOT ALLOW_SNAPSHOT_ISOLATION" returned a "What's new in ArcMap" 10.4 documentation reference. In the Geodata section it states (third bullet, emphasis mine):

Beginning with ArcGIS 10.4, geodatabases in SQL Server require the SQL Server database options READ_COMMITTED_SNAPSHOT and ALLOW_SNAPSHOT_ISOLATION be set to ON. When you upgrade your geodatabase in SQL Server, the Upgrade Geodatabase tool sets these in the database. When you create a geodatabase in SQL Server using the Create Enterprise Geodatabase tool, the tool sets these options in the database. If you use the Enable Enterprise Geodatabase tool to create a geodatabase, you must either set these options to ON in the database before you run the tool, or grant the geodatabase administrator the permission to ALTER the database. If the geodatabase administrator has ALTER database permission, the Enable Enterprise Geodatabase sets READ_COMMITTED_SNAPSHOT and ALLOW_SNAPSHOT_ISOLATION to ON in the database.

To use ArcGIS 10.4 with SQL Server databases or 10.3.1 or earlier release geodatabases, you must manually set on READ_COMMITTED_SNAPSHOT in the database.

  • 1
    Great, I have now enabled this using this: [link] msdn.microsoft.com/en-us/library/tcbchxcb(v=vs.110).aspx. I now have another error that I will research: "The version of your database server is not supported" – badgerseatfrogs May 27 '16 at 22:45
  • Probaby addressed by the requirements page (2008R2 support ended at 10.3.1) – Vince May 27 '16 at 23:04
  • interesting, I have existing 2008R2 databases that work fine but it won't let me 'enable' a geodatabase for a newly created one - since upgrading to 10.4. Has support ended but existing DB's still work perhaps? – badgerseatfrogs May 30 '16 at 22:10
  • 1
    Unsupported is unsupported. I would expect old databases to fail in unexpected ways. – Vince May 30 '16 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.