I am attempting to create an operational layer for the Flex viewer. I am having difficulty getting my mxd to publish correctly (not visible when on server). Here is the error message I get after I create a layer package and try to publish using publish tool in ArcMap 10.

Possible cause of connection failure: the soc cannot resolve the path to the data, or the soc account has not been granted read permissions of the data. In the case of ArcSDE, direct connect may not be configured properly, or the soc account may not have permission to access the database.

Any one know what I should do?

  • @Hairy - I'm seeing the error message, it's in a quote. And what do you mean by "almost added an answer"? Jan 30, 2012 at 15:31

5 Answers 5


Solution I ran into this same problem. The data was stored in SDE, connecting with an SDE user account, not the same SOC account. The problem is that SOC does not have access to the SDE connection file (.sde). This was resolved when I copied the sde connection to a folder accessible by the SOC user.


The simple answer is that when you created the MXD, you may not have checked store relative path, which is situated on the file manu in ArcMap. Open your mxd in ArcMap, check that it is/isn't set and republish it.

If it is set to storing the relative path, then the only real alternative to the error is that the MXD, or data, is situated in an area in which the SOC account has no permissions. So if the first one doesn't work, then go back and ensure that the folder the mxd is in, and all data, is shared by the SOC/SOM accounts.

When you add data to a map, the pathname to the data is stored in the map. When you open your map, ArcMap locates the data it needs using these stored pathnames. If you plan to distribute your maps to others or if the location of your data has changed, you may need to change how your map references data so that when you save the map, others will not need to repair layers.

Referencing data in the map


ArcMap will always give you a warning when you are accessing data via a UNC share. I have not found a way to turn off this error.

In windows explorer, go to the folder that contains your data, right click and select properties and the security tab. The ArcSOC account, or a user group that the ArcSOC account is a member of, must have read access to this folder. Otherwise when you publish, the server does not have access to read the data.

  • this is simply false
    – Hairy
    Jan 30, 2012 at 17:36

I have randomly received the same error when publishing a map service from ArcMap. This has worked for me when I get that error... 1. In your ArcMap Document Save Map Service Definition. 2. Close ArcMap 3. Open ArcCatalog 4. Go to the Map Service Definition you saved from your ArcMap document 5. Right Click Map Service Definition file 6. Publish to ArcGIS Server...

You are really doing the same thing, just in a different way. Not sure why it works one way and not the other, but sometimes it doesn't.

Hope this helps!


As the error says, ArcGIS server (the ArcSOC account) cannot get to the data.

You should check that the data is at a location that ArcSOC can access. The best way to find out any issues, is to use the Map Service Publishing toolbar to analyze your map.

It will often point out any issues that you could possibly face.

I would suggest that you have a look at this page Preparing resources for publishing as services You need to make sure that the ArcSOC account has read rights on the folder that contains the data. Having UNC path is not a major problem. It is just not as fast as a local path, since Networking comes into play.

Just make sure that ArcSOC account has read permissions and it should work out fine.

  • The Map Service tool will not check to see if you are storing relative paths, so will not pick up on this potential problem.
    – Hairy
    Jan 30, 2012 at 14:21
  • Thanks guys,Paths were set but still the same results I do get a warning that the layers data source is referenced by a unc path. Is there a way to fix this or to give thesoc access to the folder that contains the data?
    – jay
    Jan 30, 2012 at 15:22
  • Have you checked that you are storing the relative path as mentioned below?
    – Hairy
    Jan 30, 2012 at 16:22
  • @Hairy It's irrelevant if you are using Absolute paths or relative paths. ArcGIS server can pick up the data in either way. The problem the user is facing is that ArcSOC just can't get through to the Data Jan 30, 2012 at 17:13
  • 2
    Maybe the soc account doesn't have read permissions to the UNC path? Hold the shift key down and right click on Arcmap startup and choose "runas a different user" and enter credentials for the soc account. Then see what happens when you open the mxd being used by the mapservice. Jan 30, 2012 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.