Why this street label is not visible even with zoom?

It has 'name' in it...

enter image description here


  • You mean when you zoom in towards the feature, you still cannot see the label? – Joseph May 26 '16 at 10:09
  • Yes, but just until now. I can see it now when zoom it. – Carlos Pires May 26 '16 at 16:32

It looks like the road is too short for the text to fit on, or it's too curvy. Check here for a similar solved question. A solution could be to either abbreviate the label, or simplifying the line might help.

EDIT: if you don't want to change the road then you could use rule-based labelling and create a new rule solely for that single label:

"name" = 'R. da Fonte do touro'

For that particular label I'd suggest setting the placement as below the line, offset by a slight distance. You could then also reduce font size to fit better along the line. Repeat or add other labels with similar issues.

  • 1 - if I change scale of a map in print composer I can see it. 2 - If i delete nodes and the line change to straight line I can see it at the first scale, that is what I want. I need the curved line! Is there another way? I tried spacing and "Placement > Maximum angle between curved characters", with no luck... – Carlos Pires May 26 '16 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.