1

I have a problem displaying spatial extent in Geonetwork when I open some metadata record (as you can see from the image example). I get the right extent I previously defined in metadata editor, but when I come to the metadata view page, basemap doesn't show up.

spatial extent not showing

There was similar problem explained here in gis.stackexchange, but that doesn't work for my case.

I am using Geonetwork 3.04, just installed it on Windows XP. It is not connected to any database nor server, cause I'm not very familiar with computing and everything (I just needed Geonetwork as a catalog for spatial data).

  • 1
    You mention there is a similar problem on GIS.SE but that it doesn't work - could you provide a link to that problem and a bit of info as to why/how it doesn't work? – Midavalo May 25 '16 at 18:12
  • Sorry, it's not on gis.stackexchange, this is the link. – OBVi May 26 '16 at 7:20
  • As far as I understood, the solution for this problem is to change GetMap.java, but I can't find this file. – OBVi May 26 '16 at 7:22
1

This problem occurs if you are using proxy, but this class GetMap.java is not properly using proxy settings. You must change GetMap.java and compile it and use this new GetMap.class file.

  • I'm not using proxy. I just installed geonetwork (with this file: geonetwork-install-3.0.4-0.jar) on my C drive, followed all the installation processes, downloaded templates and samples. I didn't checked "Use proxy" in Settings and everything worked fine except this issue with Spatial extent. Before version 3.04 I worked on 2.10.4 and I hadn't had this kind of problem. – OBVi May 27 '16 at 12:35
  • Then I don't think that changing GetMap will help you (thread that you linked before was made by me), because there is problem with proxy. Do you have any restrictions or firewall that is preventing connection from outside? This url ( ows.terrestris.de/osm/… ) is called when creating thumbnail. Also check in your log if you have something relevant there. – user1403588 May 27 '16 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.