1

I have spent considerable time editing line feature classes in one of my file geodatabases in an ArcMap 10.2 map file. Today, I returned to it, opening the map file, and none of the layers appeared in the contents panel (list by drawing order). I checked out the contents tabs -- nothing shows in 'list by source', but I can finally see my database objects in 'list by visibility' and 'list by selection.' I can't open their properties, attribute tables, etc. I could still see the edits that I made there, too, so that's good at least.

Switching to layout view, nothing was there. Back to data view. Still there. Layout view, nothing. I tried toggling drafting mode. No good. Coordinates? Should be there.

I decided to move right ahead with topology to make sure my lines were all lined up properly so I could convert my lines to polygons. I enter edit mode, say I want to edit my geologic lines (weird that it shows up there, but not in the contents), open up my topology feature, select the features I want to check, and I can't open the error inspector.

Fine, so something's off and it looks like I can't just ignore it. I'm used to Arc throwing errors.

I opened ArcCatalog and opened my map document through that. Everything shows up fine in contents, etc but all of the work I did the other day is GONE!

I close all of Arc and open up the map document directly like I did earlier. My edits are there, but I have the same problems as before. I load my old line featureclass into the map document. It only shows up in the contents. I switch to layout view, and I can see the lines. But wait... where are my edits!? Switch back to data view. Ok, there they are. Back to layout view. Edits not there anymore.

I realize that I'm rambling, but I'm not quite sure how to communicate this issue. How do I recover my edits? They've clearly been saved somewhere, but not in the file geodatabase where they should have been saved... or are they? I can't check the layer properties to make sure that the data source is correct, and I'm more than half-convinced that what I see is only a "ghost" of my data, but really don't want to spend another day drawing all of those lines again.

closed as off-topic by PolyGeo Sep 1 '16 at 10:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Open it in new arcgis map. Data are valuable, map can be build again – FelixIP May 27 '16 at 19:51
  • Thanks. That's what I ended up doing over the weekend, but I pulled from an older version of the map file so I wouldn't lose all of the layer symbology (that would also have taken an age to rebuild). It turns out that my data was being updated in the geodatabase after all. That's convenient. So my data doesn't need to be recovered. The next step, then, is figuring out just what happened. Corrupted map file? Any ideas? – Breez May 31 '16 at 16:31
  • Corrupted mxd. It happens a lot – FelixIP May 31 '16 at 18:30
1

I've been experiencing the same issue. From looking at other forums and exchanges on this topic, it appears that this is a problem that has existed for years (at least since version 10.0). The most common reason appears to be corrupted mxd. One fix that was recommended and worked for me, was to use one of the pre-made layout templates that Esri provides, and then recreate your map and mxd. As stated earlier - the data is there - and very important - it's just the layout that was hosed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.