1

I have a large amount (400 shapefiles, 11 gigs total) of shapefiles which I would like to store into one file (or DB). I am also using PostGIS, but just out of pure interest I would like try test out how the files would work in a GeoPackage.

I am trying to write the files with FME into a GeoPackage and the features do get transferred and the file gets created, but when I try to open the resulting GeoPackage file on QGIS, it doesn't recognize any geometry in the file.

I was trying to go through the FME help and tried to force the file to create a spatial column, but it still doesn't seem to work as it should. The files contain only polygons and no Z-values. Any ideas what I'm doing wrong?

4
  • What if you just do it with one file? I'd suggest making a simple example and posting the shapefile and the Geopackage files here.
    – mdsumner
    May 30, 2016 at 5:12
  • What does ogrinfo find from your geopackage? You can also create GeoPackege with GDAL ogr2ogr -f gpkg output.gpkg input.shp For adding more shapefiles into existing gpkg use -append.
    – user30184
    May 30, 2016 at 6:04
  • Thanks for the comments! ogrinfo shows that FME doesn't add any geometry in the file like I was guessing. When I do one file with GDAL it works fine and ogrinfo shows polygon geometry. But what if I want to add a whole directory of shapes into the geopackage? Just putting *.shp as the input file results in erro message "Couldn't fetch requested layer 'filename.shp'" whereas individual files work just file.
    – Topi
    May 31, 2016 at 5:37
  • This still sounds like an FME bug. Have you asked your support contact about this?
    – BradHards
    Jun 25, 2016 at 22:58

1 Answer 1

2

You didn't specify the version but I can't reproduce the no geometry problem in FME Desktop 2016.1.0.1. Reading a gpx and writing to a dynamic geopackage writer results in correct geometry tables for Track & Trackpoint and an unknow geometry table for metadata.

1
  • FME writes GeometryCollection into a Geopackage and this type of geometry is not supported by QGIS. If you inspect the Geopackage directly in FME, all geometries should be there. I have tried to force FME to write fme-multi and not GeometryCollection when editing a Geopackage file, but I never have found a solution. Wait and see: gis.stackexchange.com/questions/281030/…
    – romainbh
    Apr 27, 2018 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.