1

I am trying to generate lee multiplier zone (see map please) from raster data using georeferencing and digitization. See this map only contains THREE layers!

  1. Lee Multiplier
  2. Coastal boundary
  3. Cities

I have layer 2 and 3 in shapefile format and i want to generate shapefile(vector) format of layer 1 from raster as shown.

demo

The problem is I can not correctly georeference the raster layer since Coastal boundary shapefile format is so much detailed and zigzag on the other hand raster layer (above) is so much generalized. I tried georeferencing city points with even third order polynomial (since reference point is more than 10) transformation but all went in vain.

Now can any one help me guide-

  1. the right way to georeference or
  2. share the vector data.
  • Which software are you using? Please edit your question to include the software that you are using. – ahmadhanb May 30 '16 at 10:15
  • Please add a source citation for the image. – til_b Jun 1 '16 at 12:14
  • 1
    Did you notice that in law.resource.org/pub/nz/ibr/as-nzs.1170.2.2011.pdf (AS-NZS 1170-2 (2011) (English): Structural design actions - Part 2: Wind actions [By Authority of New Zealand Structure Verification Method B1/VM1]) there is on PDF page 21 (document page 17) an updated(?) version of the figure, using rounded zones? – til_b Jun 1 '16 at 14:53
  • 1
    Hey i attached latest version and you docs has antique version! – SAZ Jun 4 '16 at 7:27
1

I just tried to georeference the image with QGIS, used just 3 points, a Helmert transformation and OpenStreetMap map as reference image.

I got to ca. 30km georeference error, and my tie points are almost on a straight line.

Using 7 points more equally distributed I get the error down to approx. 25km (more on the east coast, see image).

I used these tie points (map coordinates are in EPSG:3857):

mapX,mapY,pixelX,pixelY,enable
18817930.309071384370327,-5444407.71369334869086742,509.96686746987938932,-1318.85783132530104922,1
19814517.24758825078606606,-4672001.05644164700061083,1229.98433734939749229,-746.78915662650592822,1
19483979.98175487294793129,-4856145.33167078252881765,980.58493975903604678,-876.42048192771085269,1
19601248.11250143498182297,-4677296.48550668079406023,1073.58132530120474257,-753.83433734939751503,1
18741851.22133468464016914,-5843486.62186039518564939,472.62740963855395648,-1587.98373493975850579,1
19219123.11835713684558868,-5392862.69045551493763924,789.6605421686747377,-1270.95060240963857723,1
19691953.68777665868401527,-4794479.20610703900456429,1142.62409638554208868,-839.08102409638581776,1

30km error (Background image (c) OpenStreetMap contributors, raster image from OP (status/license/author unclear)

Maybe you can get better with using more points, and also non-city points.

Keep in mind that the line thickness of your original map is 5km.

edit: Using "Thin Plate Spline", nearest neighbor sampling, 12 tie points, I get to this:

hooray!

tie points are

mapX,mapY,pixelX,pixelY,enable
18817930.309071384370327,-5444407.71369334869086742,509.96686746987938932,-1318.85783132530104922,1
19483979.98175487294793129,-4856145.33167078252881765,980.58493975903604678,-876.42048192771085269,1
19601248.11250143498182297,-4677296.48550668079406023,1073.58132530120474257,-753.83433734939751503,1
18741851.22133468464016914,-5843486.62186039518564939,472.62740963855395648,-1587.98373493975850579,1
19219123.11835713684558868,-5392862.69045551493763924,789.6605421686747377,-1270.95060240963857723,1
19691953.68777665868401527,-4794479.20610703900456429,1142.62409638554208868,-839.08102409638581776,1
19800082.9328787624835968,-4760144.32733055297285318,1226.99013554216867306,-812.66159638554211142,1
19876439.60359066352248192,-4535857.28338263556361198,1289.86837349397546859,-650.97469879518098423,1
19259607.5276607871055603,-4083354.3287611361593008,797.41024096385490338,-312.10150602409657949,1
19267123.62052728235721588,-4189262.91006175195798278,803.04638554216808188,-391.71204819277130582,1
19386527.00492910295724869,-4353848.26180875860154629,903.08795180722836449,-516.41174698795202858,1
19257899.3247365839779377,-4944715.65329074021428823,823.47740963855346763,-957.44006024096415786,1

Dont use the Gisborne city point, it seems to be off by about 30km to the west.

The GDAL commands generated by QGIS are:

gdal_translate -of GTiff -gcp 509.967 1318.86 1.88179e+07 -5.44441e+06 -gcp 980.585 876.42 1.9484e+07 -4.85615e+06 -gcp 1073.58 753.834 1.96012e+07 -4.6773e+06 -gcp 472.627 1587.98 1.87419e+07 -5.84349e+06 -gcp 789.661 1270.95 1.92191e+07 -5.39286e+06 -gcp 1142.62 839.081 1.9692e+07 -4.79448e+06 -gcp 1226.99 812.662 1.98001e+07 -4.76014e+06 -gcp 1289.87 650.975 1.98764e+07 -4.53586e+06 -gcp 797.41 312.102 1.92596e+07 -4.08335e+06 -gcp 803.046 391.712 1.92671e+07 -4.18926e+06 -gcp 903.088 516.412 1.93865e+07 -4.35385e+06 -gcp 823.477 957.44 1.92579e+07 -4.94472e+06 "eCtlN.png" "out_eCtlN.png"
gdalwarp -r near -tps -co COMPRESS=LZW  "out_eCtlN.png" "eCtlN_TPS_NN.tif"
  • Yes I also digitized but with error! I need an most accurate ( in this case) solution if exists.. – SAZ Jun 4 '16 at 7:28
  • Then try using the points I used and transform using "Thin Plate Spline". And also experiment with more/other points. The best visible feature to check the results against is the coastline. But I think you are putting too much thought on accuracy. Your "original" map is so small scale that there will always be errors of 5-10km. The coastline stroke is approximately 5km wide. I think you would probably be fine if you digitized your zones off of a quite-good aligned image. Doesn't need to be perfect, if you are not a rocket scientist. – til_b Jun 6 '16 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.