All my units in my project are in millimeter. But I would like to switch all units to map units at once without clicking every single signature. I also would like to have the possibility to directly switch between units for the whole project.

Is there a way?

enter image description here

  • A Python script?
    – Zoltan
    Dec 11, 2020 at 11:38
  • be careful as (usually) map unit result in a lot smaller symbol than millimeter (a big point symbol set at 10 millimeter size will be displayed as a 10 meter symbol in map unit (assuming a CRS in meter), that's 0.2mm at 1/50 000 scale...) so you probably still will need to adjust the size of all your symbol individually anyway
    – J.R
    Dec 11, 2020 at 13:53

2 Answers 2


If you want to change everything to map units you can open the project in a text editor and do a find and replace:



Replace with:


If it's just for one layer. Find the section in the project file that controls that layer. Easiest with the layer name.

Search for:


Just above it will be a maplayer tag:

<maplayer simplifyAlgorithm="0" minimumScale="0" maximumScale="1e+08" simplifyDrawingHints="0" minLabelScale="0" maxLabelScale="1e+08" simplifyDrawingTol="1" readOnly="0" geometry="Point" simplifyMaxScale="1" type="vector" hasScaleBasedVisibilityFlag="0" simplifyLocal="0" scaleBasedLabelVisibilityFlag="0"\>

Which will end with an end tag:


So replace all the references within those tags.


I am not sure if this is what you are asking for, but if you have QGIS 2.14 there is an option to change the map units of the project to map unit as you can see below:

enter image description here

You can go to Project -> Project Properties -> General and under Measurements, you can change units to Map Units.

  • Thanks, but I don't want to change the measurement unit. I will change units of every single signature like you can see in the newly added screenshot.
    – MartinMap
    May 31, 2016 at 7:51
  • So you need to change the units in the Symbol layer properties. I am not sure if that option exists.
    – ahmadhanb
    May 31, 2016 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.