1

I'm trying to convert an osm.pbf file to a spatialite db but I can't get ogr2ogr to run.

I have qgis 2.14.2 and ubuntu 15.10. I've reinstalled gdal-bin and I'm getting the following message from the terminal:

ogr2ogr: error while loading shared libraries: libcharset.so.1: cannot open shared object file: No such file or directory

I've searched numerous places and I keep ending up back at instructions to install gdal.

Any suggestions?

  • How did you install qgis and gdal? From source or some repository? It looks like you are missing libcharset which probably comes from iconv. Possibly a missing dependency in the repository package spec or a failed install from source... – Spacedman Jun 1 '16 at 7:26
  • I installed from qgis.org. I'll see if I can install the package you referenced. – scdavis50 Jun 1 '16 at 14:12
  • So I went back and checked; I installed gdal with sudo apt-get install gdal-bin, although I can't find the repository. QGIS i installed from the ubuntugis repository. I installed iconv earlier this morning but it still didn't run. – scdavis50 Jun 1 '16 at 22:39
  • so I ran it on my desktop which has (I thought) the identical configuration to my laptop - ogr2ogr runs fine. Re-installed GDAL and QGIS on the maptop, not sure why it's still not working. – scdavis50 Jun 4 '16 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.