2

I joined a sqlite layer with a csv table (each attribute field name starts with a capital letter). When I create a new layer out of them ("save as", e.g. as a new sqlite layer with all data combined), the attribute field names in the new layer are changed to lower case. The entries in the table are not affected, though - only the attribute field names (= column title, to say it differently).

Does anyone have an idea how I can save a join of a spatialite layer and csv table and at the same time keep the original attribute field name that is case-sensitive? I also tried to use a different codification, but this did not help.

  • 1
    Have you tried Table manager plugin? – wiltomap Jun 1 '16 at 8:42
  • Yes, I tried. The table manager truncates my attribute field names... sadly. – Nevhis Jun 1 '16 at 9:05
1

Just for future reference because I was able to solve my problem:

If you want to create a new spatialite layer without having changes in the attribute field names (e.g. upper case to lower case), then you need to change the layer option LAUNDER in the 'save as' option form to "NO".

enter image description here

Now the new spatialite layer possesses exactly the same attribute field names as the original layer (and thus is also case-sensitive).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.