1

I have noticed strange behaviour with the Dissolve tool so tried a test on three line segments, snapped to the same central point. The line segments each consist of exactly two vertices i.e. the end vertices. There are no vertices in between.

When I ran the dissolve tool on this (multipart deselected, for testing purposes), I got a new feature class consisting of five records: two of the original line segments had been split in two! I was expecting to get a new feature class with a single record, as all the lines shared a vertex. At the very least, I didn't expect to get more records in the output feature class than were in the input feature class.

Anybody have any ideas as to why it might be behaving this way?

  • I just ran a test using 3 line segments in UTM,with ArcGIS 10.4. The output from Dissolve has 3 lines, as expected. Is any of your input lines Multi-part? If you start editing, look a the sketch property on the Edit Vertices toolbar. – klewis Jun 1 '16 at 20:11
  • Hi. None of the lines are multipart. There are three line segments that have been digitised so that an end point of each one overlaps a common, central point. – Jamie Crawford Jun 2 '16 at 19:10
0

The answer was very simple. I tested dissolving line features but did not use a basemap to get a sense of size or location. The line segments were being split by the dissolve tool because they extended over the edge of the map once a basemap was added in. This shows how important it is, when testing out geoprocessing tools, to be mindful of the location and size of the test features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.