0

Tried renaming and deleting the ESRI folder in C:\Users\Mus\AppData\Roaming, no luck... Using Windows 7 SP1 32 bit system. When I start ArcMap 10.3 it shows the the program is initializing and loading document... but nothing opens. But ArcCatalog is working fine. Any suggestion?

  • Are you trying to open direct to an MXD or to ArcMap itself? – Midavalo Jun 4 '16 at 22:41
  • Have you added any new toolbars or Add-Ins recently? – Midavalo Jun 4 '16 at 22:42
  • Tried both, nothing is working. – Mac Jun 4 '16 at 22:42
  • No, didn't add anything. – Mac Jun 4 '16 at 22:43
  • But, I installed JDK recently, do you think that can cause this? – Mac Jun 4 '16 at 22:44
2

We just had a similar issue with 10.4, where it wouldn't load ArcMap and then crash and give no error or indication of what happened. Event viewer and checking logs didn't show anything suspicious. It had to do with python libraries being updated back in December. You can fix this by editing your registry.

Try some of the solutions listed in Problem: ArcMap crashes during Loading Document launch stage:

ArcMap unexpectedly exits during the "Loading Document..." stage on startup. No error code is displayed.

  • 1
    Thank you so much. This was the real problem. Thanks a lot. I have been struggling with this for last 2-3 days. The only thing is, I am using a 32 bit OS and the location of the "2.7" folder in Registry was not exactly at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.7 , in my case it was at HKEY_LOCAL_MACHINE\SOFTWARE\Python\PythonCore\2.7 . I changed it there and now its working fine. Thanks again. – Mac Jun 5 '16 at 17:07
  • Glad it worked! Super annoying when there's no helpful error code to troubleshoot. – GISKid Jun 6 '16 at 15:09
2

Just go to C:\Users*%%%*\AppData\Roaming\ESRI\Desktop10.2\ArcMap\Templates => Delete "Normal" file (Or rename it). And Open ArcMap. I Did and succeeded. ^_^ Hope it is useful for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.