1

I have a point shapefile in QGIS where I am manually adjusting some of the points due to overlap. I am using Toggle editing --> Move feature(s) --> Save for all layers. Instead of moving the points these are duplicated. The original point stays where it is, in addition an extra point is created wherever I move it to. This does not seem to lead to any any additional entries in the attribute table.

Any ideas about what I might be doing wrong?

  • Interesting. I tried the same in 2.8.7 and everything works as expected. Do you have write access to your shapefile, is it opened anywhere else or sth? – Jochen Schwarze Jun 7 '16 at 8:28
  • I have write access, and it is not open anywhere else. – Lilly Jun 7 '16 at 8:44
  • Is it possible that the shapefile is corrupt? Could you make a copy of the shapefile via rightclick > save as.. and try again with the copy? – Jochen Schwarze Jun 8 '16 at 9:45
1

It sounds like you have multiple points stacked on top of each other. Try dragging a selection box over a point and check the attribute table to see how many features you have selected. If it really is duplicating then you might want to update QGIS to a newer version (2.14) and try it again.

  • I had an older version of QGIS on a different laptop, and this worked as expected. – Lilly Jun 7 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.