1

I have attached geodatabase "Riverside" to databases list in MS SQL SERVER 2012 Enterprise edition :

enter image description here

After that I created two logins using :

   USE [master]
GO
CREATE LOGIN [sde] WITH PASSWORD='sde_class', DEFAULT_DATABASE=[master], DEFAULT_LANGUAGE=[us_english], CHECK_EXPIRATION=OFF, CHECK_POLICY=OFF
CREATE LOGIN [GISADMIN] WITH PASSWORD='gisadmin', DEFAULT_DATABASE=[master], DEFAULT_LANGUAGE=[us_english], CHECK_EXPIRATION=OFF, CHECK_POLICY=OFF

Then I tried to add a database connection from catalog window within ArcMap ,but the connection failed :

enter image description here

After that I went to security folder inside the "Riverside" I found a user with name "GISADMIN" . I thought I could delete this user and create another user with same name . The deletion failed ,

enter image description here

my last option was mapping this user"GISADMIN" to the login "GISADMIN" .

use RIVERSIDE
go
exec sp_change_users_login 'GISADMIN', 'gisadmin'
go

Nothing changed!
I'm using ArcGIS 10.3 running on Windows 7 machine.

  • Did you already enable the geodatabase, i.e. run the Enable Enterprise Geodatabase tool from ArcMap / ArcCatalog? Adding a new user is in my experience easier to do from within ArcMap: right click on the database connection and select Administration > Add user. – Berend Jun 7 '16 at 10:50
  • "Add User" works on active connection , it's disable in this case. – salambshr Jun 7 '16 at 11:00
  • 1) You cannot change the database name when attaching a geodatabase. 2) You will likely need to use sp_change_users_login to de-corrupt the users after the attachment process 3) Be hyper-aware of case sensitivity - I NEVER use UPPERcase anything in object naming (not databases, not users, not schemas, not tables, not columns) – Vince Jun 7 '16 at 11:07
  • Yeah, you need an active connection using an administrative user to do that. But the database must be geo-enabled first anyway. That is, the SDE tables should be there, as well as the sde user. There must be a valid license set in the database too. – Berend Jun 7 '16 at 11:08
  • Yes it's already geo-engabled . – salambshr Jun 7 '16 at 11:29
1

It's working:

  1. Go to "Database Connections" in the catalog window or ArcCatalog.
  2. Double click "Add Database Connection" a dialog box will open and authenticate as Database Administrator "sa" or using your windows authentication is the user part of sysadmin.
  3. Click OK, another dialog box will pop up asking you to provide a path to license file give it the path, and then everything will work fine .
  • Good to hear - this appears to be a handy shortcut to the method in my answer above – Midavalo Jun 8 '16 at 7:32
0

You need to provide your geodatabase with a license to use in an enterprise database environment.

Run the Create Enterprise Geodatabase tool and provide the license or authorization file in order to license your database.

This tool needs to be run even if the database already exists - if it exists you just point it at the existing database and it will authorize it. If it doesn't exist it would also create it and set up the SDE tables (not applicable in your case).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.