2

I'm trying to add a .tif into Google Earth Pro as a superoverlay. The file is a large island survey I georeferenced in ArcGIS, and I'm trying to preserve its high quality and coordinates.

When I try to open the file, I get the error "Unknown error on image ingest" and the file shows up under Places as a camera icon image, but even then there's no image to be seen in the view window.

A couple people on the internet have had this happen before, but they didn't receive answers. Do you have any advice?

1

Please forgive my resurrecting an old question, but I've stumbled upon something that might help someone else.

I was getting the same error on an image I'd georeferenced. Turns out I'd saved it in a weird projection and apparently Google Earth doesn't like it. To fix this, I used QGIS/gdal_warp to reproject it to the standard WGS84 (EPSG 4326) projection.

To figure out what projection your file is in, load it into QGIS, bring up the layer properties, go to the Metadata tab, scroll down to Properties, and then scroll within Properties to "Layer Spatial Reference System".

To reproject your file in QGIS, go to Raster -> Projection -> Warp (Reproject). Select the input and output file names and choose WGS 84 as the Target SRS. If your file is big (mine was 400+ mb), check the "Creation Options" box and select one of the compression options. This brought mine down to ~85 mb.

0

If you are seeing an camera icon, then I believe you may be importing the image as a "Photo Overlay" rather than as a georeferenced "Image Overlay" as you appear to intend. It's an unfortunate terminology issue with Google Earth. I've never seen the error message you report, but have seen other weird behavior when I accidentally triggered the "Photo Overlay" process.

Make sure your image is a geotiff, not a tif with separate tfw file, which GE tends to treat as a Photo Overlay.

My preferred way to trigger the georeferenced Image Overlay import is to drag and drop my geotiff onto GE. If the file is so big that it requires tiling into a superoverlay, I'm prompted to either create that superoverlay or scale the image. I'm using Windows, so I can't speak for other operating systems.

0

I used gladinfo gdalinfo input.tif > info_about_info.txt and compared two files; one of which worked in Google Earth while the other threw the Unknown Error.

I discovered that the images (who had both one band) had different data types. One featured Float64, the other one Int16. Therefore some gdalwarp to change Float64 to Int16 and that was it.

gdalwarp -ot Int16 input.tif output.tif

The import to Google Earth worked like one would expect. Maybe this is of help to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.