5

MAC OSX 10.11.13 New machine clean install of QGIS from Kyngchaos Installed Current version 2.14.2-Essen

When I try to run a GRASS command e.g. v.clean

I get the following error: This algorithm cannot be run :-( It seems that GRASS GIS 7 is not correctly installed and configured in your system. Please install it before running GRASS GIS 7 algorithms.

This algorithm cannot be run

I have searched to see if there is a particular issue with this. I did not find a clear solution as it appears this occurs quite often. It does appear that the folders for the GRASS install do not exist on my machine and that likely the install failed to load GRASS.

enter image description here

Is it better to do a reinstall and hope for a better outcome or try to reinstall GRASS alone?

  • Have-you read Grass7 processing toolbox QGIS with the detailed solution ? – gene Jun 8 '16 at 6:31
  • Did you install Grass7? QGIS 2.14 ships with GRASS 6. Check if the GRASS 6 algorithms work. – Simbamangu Jun 8 '16 at 13:54
2

It's not an operation system issue, but a QGIS installation one. There's no MSYS folder with the 2.14 standalone installer. Either follow the tips in the question and answers at QGIS 2.14 standalone GRASS provider missing Msys folder, can't execute tools, or perform an advanced install of 2.14, which does come with MSYS (verified so yesterday).

  • In OS X, how do you get an 'advanced install'? – Simbamangu Jun 8 '16 at 13:51
1

I think you need to install GRASS 6 on your system to include Minimal System (MSYS) because GRASS 7 doesn't include MSYS. The GRASS 7 tools keep looking for MSYS which is not exist. After installation, if you still receive the same error, then you need to set the correct path of the folder where MSYS is installed from Processing Options.

  • Is it possible to have both GRASS 6 and 7 installed simultaneously? Also have ben researching further it appears that GRASS cannot run on OSX El Capitan. Does this also apply to GRASS 6? – user75698 Jun 8 '16 at 2:16
  • I am not sure about Mac, as I faced the same error in Windows, and it was solved as I explained. GRASS 7 doesn't work below QGIS version 2.12 in Windows, so maybe it is not yet ready for Mac OSX. But try to install GRASS 6 as msys exist in GRASS 6 installation. – ahmadhanb Jun 8 '16 at 2:25
  • SO I disabled CSRutil per instructions located here: grassmac.wikidot.com I also downloaded and installed GRASS 6.4.4-3 from Kyngchaos. This appears to have installed correctly. However it did not solve my original issue and none of the GRASS GIS 7 commands in the processing toolbox are working and the same error message is generated. I'm back to where I started. Any ideas? I've tried locating the msys but can not locate it. where would this be. I looked in Library/grass/6.4/ but can not find an msys file. – user75698 Jun 8 '16 at 3:41
  • Have you tried to search for msys under QGIS folder. For example C:\Program Files\QGIS Essen\apps. Then you will find msys folder located there. – ahmadhanb Jun 8 '16 at 3:58
  • Also, I found this question on GIS SE, but it is for windows. Please check it. gis.stackexchange.com/questions/183261/… – ahmadhanb Jun 8 '16 at 4:00
1

I had the same problem under MacOSX 10.12.6 with QGIS 2.18.13 (it was the second update I had made, since the first update GRASS 7 extensions would not work), I tried reinstalling QGIS and GRASS, didn't work.

Then I made a backup of the folder /Users/yourusername/.qgis2 and deleted the original one, reinstalled QGIS, now it works.

It seems the msys problem is an obsolete option that stuck the whole thing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.