3

I have installed QGIS (2.14.3-Essen) along with SAGA GIS (Version: 2.2.7) in Ubuntu (14.04 trusty). I am trying to fill the sinks in a DEM in QGIS processing using SAGA provider. I have used both the conventional Fill sinks and Fill sinks xxl (wang & liu) commands. But it gives me the same error.

Following is the content of the log for the command. The error is seen at the last line, where it says that the Filled DEM could not be generated correctly. Could anybody please help me with this error?

Following input parameters were supplied:

  1. DEM: A 30m SRTM DEM

  2. Minimum Slope (Degree): 0.10000 (Also tested with 1.0000 and 0.01000, and that also gave the same error).

Log output:

Algorithm Fill sinks xxl (wang & liu) starting...
ta_preprocessor "Fill Sinks XXL (Wang & Liu)" -ELEV "/tmp/processingd598aea9706848d19dfbd7650d1adaec/dc79aa0c5343429683c3aedae3409e64/clippedbagmati.sgrd" -MINSLOPE 2 -FILLED "/tmp/processingd598aea9706848d19dfbd7650d1adaec/f96c3d2452e642d789f4b534cf63960b/FILLED.sdat"
____________________________

##### ## ##### ##
### ### ## ###
### # ## ## #### # ##
### ##### ## # #####
##### # ## ##### # ##
____________________________

SAGA Version: 2.2.7    
____________________________
library path: /usr/lib/x86_64-linux-gnu/saga/
library name: libta_preprocessor
library : Preprocessing
tool : Fill Sinks XXL (Wang & Liu)
author : Copyrights (c) 2007 by Volker Wichmann
processors : 4 [4]
____________________________

Load grid: /tmp/processingd598aea9706848d19dfbd7650d1adaec/dc79aa0c5343429683c3aedae3409e64/clippedbagmati.sgrd...

Parameters    

Grid system: 29.444285; 3159x 2645y; 600784.721897x 3000440.861314y
DEM: clippedbagmati
Filled DEM: Filled DEM
Minimum Slope [Degree]: 2.000000

Converting outputs
Loading resulting layers

The following layers were not correctly generated.
Filled DEM
You can check the log messages to find more information about the execution of the algorithm

#################################
  • Welcome to GIS.se! Please click 'edit' and give more information about the input data and the exact parameters you entered. – Simbamangu Jun 9 '16 at 6:11
  • I have included the information on input data and the exact parameters used. – Main Boy Jun 23 '16 at 17:04
  • It seems to work for me with an original SRTM input file. Have you reprojected your DEM before feeding it to SAGA? Can you try an original file too? – AndreJ Jun 25 '16 at 6:03
  • Are your Ubuntu, QGIS and SAGA-GIS versions same as mine. I ask this because I fear the incompatibility between the versions of these three. – Main Boy Jul 21 '16 at 19:14
  • And yeah, the DEM was a (re)projected one. – Main Boy Jul 21 '16 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.