5

I'm running a basic buffer tool on a polyline shapefile (teal line), to create a 50km buffer (beige) around it. However, ArcMap appears to only buffer part of the map (see image below).

How can this be worked around? Is the polyline too complicated?

I have already used the simplify line tool to try and speed up the process.

Storage type of buffer target: Shapefile

Co-ordinate system: WGS84

Co-ordinate resolution: Initially 1:250,000, but run under a 'Simplify Line' to a simplification tolerance of 0.5km

Desktop Version: 10.2

Buffer failure...

closed as off-topic by PolyGeo Jun 24 '16 at 23:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Perhaps there are errors in the geometry of your line shapefile? You can check this by Data Management Tools > Features toolset > Check Geometry. If so, consider running the Repair Geometry Tool and then try buffering again. – Joseph Jun 9 '16 at 10:44
  • 2
    Please edit the question to specify the storage type of the buffer target (shapefile, file geodatabase,...) and the coordinate system and coordinate reference details (especially the XY Resolution). Please always include the version of Desktop in use with each question. – Vince Jun 9 '16 at 10:57
  • 3
    Coordinate resolution is in the units of the dataset (decimal degrees). Have you tried writing to file geodatabase, which has more topological capability? 10.2.2 was the terminal release of 10.2.x. I highly recommend you use that (or 10.3.1, or 10.4.1) over 10.2.0. – Vince Jun 9 '16 at 12:11
  • What happens when you Select an island that appears not to have buffered (like Sicily) out into a separate feature class? Does it buffer using the same settings? – PolyGeo Jun 10 '16 at 10:03
  • Apologies for not replying sooner - none of the above fixes had any affect. However, the process worked in the end by using a smaller sized dataset (the original file was in the order of several gigabytes). I think this was an internal RAM limitation which caused the issue – GneissDay Jun 15 '16 at 9:53