1

I have a map service I am testing on internally with some popups on a dynamic map service layer. They work perfectly in Firefox (version 45.0.1), but not in Chrome (version 50.0.2661.102) or Internet Explorer (version 11.0.96 on my computer). I am using the ArcGIS JS API 3.16.

These are the only meta tags I have in my HTML file:

<meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
<meta http-equiv="X-UA-Compatible" />
<meta name="viewport" content="initial-scale=1, maximum-scale=1,user-scalable=no"/> 
  • juturna, can you share the Map Service URL or is it private? Can you share the code of the web application you're using the view the map service? Or are you viewing it through the "View In: ArcGIS JavaScript" link in your ArcGIS Server REST Page? – GavinR Jun 11 '16 at 20:36
  • 1
    Try to debug the applicati on. Press F12 and find errors in Console tab. – lele3p Jun 16 '16 at 5:23
2

When modern browsers behave dramatically differently it is usually worth validating your HTML using an online validator such as https://validator.w3.org/ since how they handle invalid html varies much more than how they handle valid html. In particular look for unclosed tags in the popups. If you can't get this to work I suggest posting the content of one of your popups.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.