3

I work with rasterized extracts of CORINE data (V 18.5 gdb) in QGis. My layers however are not depicted in the colours that are standard for CORINE, but in different shades of red. From EEA i downloaded the correct colour map for QGis as qml.

http://www.eea.europa.eu/data-and-maps/data/corine-land-cover-2006-raster#tab-additional-information

I tried to add it via properties/style/style/load style and nothing happened. Then I used the MultiQml plugin, now the whole map appears white. However, when i click on the map with identifier the correct numbers are shown and in the style properties the correct legend is displayed. I remember that I had a similar problem with styles in QGis some time ago, but dont remember how i solved it. I checked the original corine data raster data to compare the style and registered that CORINE rasters have only one band, while mine have 3. Might this be the source of the problem?

closed as off-topic by underdark Jun 12 '16 at 12:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

1

I cannot reproduce your issue here, loading the .qml from the page you linked styles the 250m raster as expected:

enter image description here

  • I adjusted my question. I work not directly on the original CORINE data. When i download this 250m grid it is by default already in the correct style. However, my data is processed - clipped, rasterized to 20m solution and has three bands instead of one. – Philipp Dahlem Jun 12 '16 at 5:56
1

Question can be closed, I detected the problem myself, registered that somewhere in my code i assigned new numerical values to the raster cells that are identical with the corine codes. The original data and the qml however are based on values fron 1 to 45 instead of the land cover class codes such as 111, 112...

I just had to change the numbers in the qml as well and now it fits, however only when i load the style via properties. With the tool, it still does not work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.