2

When I try to set CRS in geotools application first time it works great but after that I get FactoryNotFoundException it shows me this in console

Exception in thread "AWT-EventQueue-0" java.lang.RuntimeException: org.geotools.factory.FactoryNotFoundException: No factory of kind "CRSAuthorityFactory" found.
    at org.geotools.swing.dialog.CRSListModel.<init>(CRSListModel.java:87)
    at org.geotools.swing.dialog.JCRSChooser$CRSDialog.createControlPanel(JCRSChooser.java:248)
    at org.geotools.swing.dialog.AbstractSimpleDialog.initComponents(AbstractSimpleDialog.java:137)
    at org.geotools.swing.dialog.JCRSChooser$CRSDialog.<init>(JCRSChooser.java:241)
    at org.geotools.swing.dialog.JCRSChooser.doShow(JCRSChooser.java:202)
    at org.geotools.swing.dialog.JCRSChooser.showDialog(JCRSChooser.java:154)
    at org.geotools.swing.menu.JCRSPopupMenu.setCRS(JCRSPopupMenu.java:137)
    at org.geotools.swing.menu.JCRSPopupMenu.access$000(JCRSPopupMenu.java:50)
    at org.geotools.swing.menu.JCRSPopupMenu$1.actionPerformed(JCRSPopupMenu.java:81)
    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    at javax.swing.AbstractButton.doClick(Unknown Source)
    at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
    at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$500(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue$4.run(Unknown Source)
    at java.awt.EventQueue$4.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: org.geotools.factory.FactoryNotFoundException: No factory of kind "CRSAuthorityFactory" found.
    at org.geotools.factory.FactoryRegistry.getServiceProvider(FactoryRegistry.java:375)
    at org.geotools.factory.FactoryCreator.getServiceProvider(FactoryCreator.java:145)
    at org.geotools.referencing.ReferencingFactoryFinder.getAuthorityFactory(ReferencingFactoryFinder.java:220)
    at org.geotools.referencing.ReferencingFactoryFinder.getCRSAuthorityFactory(ReferencingFactoryFinder.java:440)
    at org.geotools.swing.dialog.CRSListModel.<init>(CRSListModel.java:71)
    ... 46 more

at first I thought that this is something because my code but I get the same exception in all apps I have(Quickstart). If I export shapefile with geotools app, and run it again I get this exception at first try to set CRS.

0

This was a bug but is now fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.