1

I'm a newbie to QGIS.

The waypoint data was collected on a Garmin etrex legend H, with the grid set to OSGB36. Using Garmin's Basecamp software, I saved the waypoints as a gpx file (also xml etc with roughly the same result). The survey data was taken in Dorchester, southern England.

I imported the data into QGIS using the GPS Tools plugin (in QGIS Essen). The co-ordinate system in QGIS is OSGB36. However the waypoints appear not in Dorchester, but somewhere south of Madagascar - interesting but not useful!

In DEFRA's Magic Map, one point for example should be 369002.6, 90328.4. However this point is shown in QGIS as -2.440391, 50.711678.

  • 2
    A gpx file is on lat lon WGS84 CRS, take a look at the coordinates in your example. You need to load the gpx and save it as a shape file, asking to change the CRS to the one you want. – Gerardo Jimenez Jun 13 '16 at 18:44
  • Thanks Gerardo. I've saved as a shapefile as you suggest and changed the CRS to OSGB 36. However, the coordinates haven't changed. – Phil C Jun 14 '16 at 14:36
  • Did you change the CRS in the layer properties or when you saved as a shape file?Usually when you load a gpx file it detects that it is on 4326 (lat lon wgs84). When you select the waypoints layer, for instance, choose save as, give a name and the file type (esri shape file). Then in the CRS section you have to select the globe icon that lets you select the desired CRS. – Gerardo Jimenez Jun 14 '16 at 15:26
  • I made an experiment, defined the coordinates you cite as a text layer. Then I saved as a shape file and asked for EPSG 27700 for the new crs. I then calculated the east and north values for the point. I get: 369002.28, 90319.85, which is only 9 meters away from the Defra´s magic map coordinates... so can you tell us what exactly are you doing to transform the layer? This is in order the improve the answer. – Gerardo Jimenez Jun 14 '16 at 15:47
  • Thanks for your efforts, which I appreciate. I will come back to this shortly, but essentially I seem to have tried to change the CRS both during the 'save vector file as' dialogue during shapefile creation, and after saving as a shapefile in WGS84. I can't seem to get rid of the lat lon any way, and the points remain west of Africa even though the layer properties description says that the CRS is set to OSGB36. The base map of Dorchester is a georeferenced raster map, but I shouldn't think this wold make a difference? – Phil C Jun 14 '16 at 16:29
1

I do not know exactly what are you doing, I did the following experiment. First, From the point you mention I created a csv file. Then I used gps babel to create a gpx file from the csv (you do not need to do this). This is the point in google earth

enter image description here

I loaded the gpx file in QGis using GPStools (vector/GPS/Gpstools). When you load a GPX file Qgis separates the way points, tracks and routes as different layers. Waypoints are defined as a point layer, tracks and routes as line layers. I did have a waypoint so I have only a point layer in my project. Also take in to account that the coordinate system of a GPX file is lat lon with WGS84 datum (EPSG 4326).

I selected my point layer (the waypoint), right click and choose save as. This is the dialog box:

enter image description here

In the format section I want a ESRI shape file. I give a name and where I want to be stored in my computer.In the CRS section I choose the globe icon which let me select the coordinate system that I want. This is the dialog box:

enter image description here

In the filter I write 27700, select OSGB 1936 British National Grid EPSG 27700 and I can see the parameters. In the image you can see the things I mention in the elipses. In my experience it is mandatory to select the coordinate system you want and check its parameters before selecting ok. Once you hit OK you will have this dialog box:

enter image description here

Notice that the CRS section has changed and now shows "selected CRS (EPSG 27700, OSGB 1936/British National Grid)". Also notice that I did not want to add the saved file to map. When I am reprojecting I do not do this because Qgis will load the layer and will also activate "on the fly reprojection" in order to show all the layers in the project even though they are in different coordinate systems. Now I select ok

In order to check if everything is without problems I define a new project (poject/new) and load the reprojected shape file.

enter image description here

Notice the coordinates, they are no longer in lat lon, also chek the EPSG code of the project, now is set to 27700. Finally, I calculated the east and north values of the point with the field calculator and this is what I get

enter image description here

Hope it helps

Gerardo

  • Well, the waypoints are now in Dorchester! There is a slight discrepancy in plotted and real world positions, but I assume this is inherent inaccuracy in the Garmin device positioning – Phil C Jun 17 '16 at 11:22
  • Well, the waypoints are now in Dorchester! There is a slight discrepancy in plotted and real world positions, but I assume this is inherent inaccuracy in the Garmin device positioning. I originally used an epsg of 4277 (OSGB 1936) rather than your 27700, however I gather that the difference is that the former is measured in degrees and the latter in meters - would 27700 (which I have now used) rather than 4277 make any difference at all to the positioning of the base map ? – Phil C Jun 17 '16 at 12:17
  • Many thanks for your help Gerardo, much appreciated! – Phil C Jun 20 '16 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.