3

I am running cluster analysis from image analysis menu of saga provider in QGIS. I use the qgis GUI from processing tool box, I call saga modules. I got same error in many other algorithms. I can read this lines:

Log pannel shows this message

io_gdal 0 -TRANSFORM 1 -INTERPOL 0 -GRIDS ....

After other lines

Unknown option 'INTERPOL'

It seems to be that I am running wrong version fo qgis, gdal or saga in my system.

I am runnig

  • Linux Mint 17.3 64 bits
  • qgis 2.14.3
  • saga gis 2.2.7
  • gdal 1.11.2+dfsg-1~exp2~trusty

I made udate and upgrade in my system and got no difference.

5

I guess I found an ugly side of free software here.

One side, qgis programers really knows this problem since 10 months ago. They dicieded it is not their responsability to solve this problem and I found they are planning to drop support to SAGA.

The other side, SAGA is producing now more frequently new versions. Each new version with different name in parameters. It makes harder to link into qgis.

Normal user, like me, found that my updated system even with LTS (long term support) already found no support for the problem. The bug report is open now.

A month ago Max Bohnet presented his solution to this problem

But for my suprise, his message was marked as rejected because is a duplicate of another report presented by Paolo Cavallini 10 months ago.

Thanks to Bohnet, I found a folder in my system where are the versions of SAGA supported.

/usr/share/qgis/python/plugins/processing/algs/saga/description

Now I have to consider to apply a downgrade of SAGA to keep connection in qgis. I am planning to follow instructions from howtogreek.

In consequence, I will drop some new algorithms and improvements of SAGA. Another option I have is to write files like proposed by Bohnet and try to connect new SAGA versions to qgis. At this time I have not time to do.

1

I just ran into the same problem and fixed it. There are a number of files other than the scripts (namely the description files) where INTERPOL shows up as a parameter, and it needs to be changed to RESAMPLING in those as well as the scripts. (See my answer to this question.) I did my fix within the version 2.2.3 directory, but you can do something similar.

0

I made a solution based on Max Bohnet ideas.

In folder /usr/share/qgis/python/plugins/processing/algs/saga/description

I found this folders

2.1.2
2.1.3
2.1.4
2.2.0
2.2.2
2.2.3

There is no documentation I found previously about this problem. I supposed every code is a version of saga gis, then I created a new folder

2.2.7

Next, I copied all the content of 2.2.3 folder in new 2.2.7

I did a copy of /usr/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithm214.py to /usr/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithm227.py

Then I did edition of SagaAlgorithm227.py

Line 29 : from SagaAlgorithm214 import SagaAlgorithm214
Line 36 : class SagaAlgorithm224(SagaAlgorithm214):
Line 40 :         newone = SagaAlgorithm214(self.descriptionFile)
Line 64 :         return 'io_gdal 0 -TRANSFORM 1 --RESAMPLING 0 -GRIDS "' + destFilename + '" -FILES "' + source + '"'

I also edited file /usr/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithmProvider.py

Line 54 :                          "2.2.7": ("2.2.7", SagaAlgorithm214)}

Now, cluster analysis is runing. I am not sure with the rest of the modules.

Final SagaAlgorithm and agaAlgorithmProvider editions are in this folder.

  • I am afraid that Cluster Analysis is not working now. – jlopez Jun 16 '16 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.