1

I have set up a project and print composer to generate an atlas so I can print off some 300 pages of feature coverages.

I have selected "Preview Atlas" and entered in settings for Atlas Generation and Controlled by Atlas from the item properties. I am able to navigate through the pages as normal, but when I "Save as Image", QGIS returns the empty files with the names of the coverage layer; which doesn't work.

Have I missed any steps or settings? I also downloaded and installed QGIS 2.14.3 Essen, which behaves the same.

  • Are you using the openlayers plugin? – ndawson Jun 15 '16 at 21:35
  • No. I am using shapefiles running locally. Our network at work has ported out all plugins. – TwoPunchMan Jun 16 '16 at 13:03
1

I attempted to successfully export images when the "Output filename expression" only had one field in the expression, rather than specifying two and some text strings.

Doing some searching online this does not seem to be a known issue to the QGIS community.

  • The issue can be intermittent. If I run Export Atlas as Images, 5 maps were output with an empty main map area (all other items were fine); the maps rendered fine if done one-by-one. There was nothing special about any of the 'missed' maps in terms of feature count or styled-feature count; it wasn't because of a transition from portrait to landscape or vice versa; reordering didn't change which maps failed. Using the same Atlas with output to PDF worked perfectly, both PDF-per-map or a portmanteau PDF. Filenames were @atlas_pagename || '[_suffix]'. Memory issue, maybe? – GT. May 19 '17 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.