3

I had installed QGIS 2.14.0 (or .1 not sure) and I did some work with the GRASS plugin a couple of months ago, so it was there.

I upgraded a couple of weeks ago to QGIS 2.14.3 and I was planning in using the GRASS plugin is now missing.

GRASS is installed and works from the Processing tools, but the plugin is not to be found anywhere... (and yes the I have installed the plugin with sudo apt-get install qgis-plugin-grass)

. My setup

I have been looking for a solution and none of the ones I found seem to work. The closest one was this one but none the answers changed the situation.

(System: GRASS70, QGIS 2.14.3 Essen in Ubuntu 14.04)

Update: I found out that the grass-plugins that I have in my machine are "libgrassplugin6.so, libgrassprovider6.so and libgrassrasterprovider6.so". So the problem seems to be that I have GRASS 7 installed but the plugin is for GRASS 6, right?

Update2: I found this question in the users list (sorry I did not look earlier) and seems to be the same/similar problem... from the answers there you don't quite find the solution but I am working on it...

2

I found a solution! Hope it helps others.

First thing was to find out what the real problem is. I would think that the problem is likely that I ended up having repositories (somehow changed them in between updates to QGIS) which leads me to have GRASS 7 installed with a QGIS version trying to use a qgis-grass-plugin for GRASS 6... See the question and updates in above.

Solution, find the correct repositories and update as necessary until you have a consistent set of versions. That is, GRASS 7 and qgis-grass-plugin for verion 7... and make all of the packages have the same version!

I started with these repositories: # deb http://qgis.org/debian trusty main and # deb-src http://qgis.org/debian trusty main.

First comment those two out (or the ones you have).

And then add those highlighted in the picture... you can find those in the QGIS installation pages.

Then update the list using for example Synaptic or via the terminal. You can see in the left side of the picture that I have already updated the list but still have the libqgisgrass6-xx packages active and the libqgisgrass7-2.14.3 waiting for installation.

starting repositories and fixed ones

After installing the libraries referencing GRASS 6 and installing the one for version 7 you would probably there... here is the situation now (but see below for an additional possible complication)

enter image description here

I still had the problem that the grass-core package was still 7.03 while the rest of grass packages were 7.04... upgrade that too or you will not have the grass-plugin available yet.

In this picture you can see that I have already upgraded grass-core to 7.04 and now I can finally use the GRASS 7 plugin in QGIS 2.14.3!

enter image description here

Comments? experiences?

  • I tried to do this solution in qgis 2.14.4 but it wasn't work well. – Diogo Caribé Jul 20 '16 at 23:51
  • Hi Diogo, what was your result? in the end my problem was caused (I think) by different versions of grass installed. – eglatorre Jul 27 '16 at 7:24
  • this solution worked, but it update to qgis 2.18.x possibly because my repos are messed up. but i tried this soln here hub.qgis.org/issues/10714 and now grass plugin in the processing toolbox works alright! – csheth Apr 11 '17 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.