1

I've just started using QGIS (2.6.0-Brighton). Every time I create a new polygon, a circle appears in the center (see below). I thought this might just be a feature of QGIS editing that helps you to distinguish between new polygons, but the circles stay there even in the print composer and exported maps. Any ideas on how to remove them?

enter image description here

closed as off-topic by user30184, Andre Silva, Mapperz Jun 15 '16 at 13:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – user30184, Andre Silva, Mapperz
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have a look at Layer-Properties-Style. I guess that your layer has something like "Centroid fill" in the renderings styles. Remove it. If you are just beginning to use QGIS you should have no reason to start with 2.6 because the current version is 2.14. – user30184 Jun 15 '16 at 11:45
  • Neither of the polygons use 'centroid fill'. But I've just realised that for some reason 'display diagrams' was switched on in the 'Diagrams' tab (in Layer Properties). This seems to have resolved it. Thanks for your suggestions - I'm in the process of downloading the latest QGIS now! – user32476 Jun 15 '16 at 12:44