1

We're experimenting with ArcGIS for Server (10.3.1) on CentOS (6.7) and I've run into a wall; specifically this:

Service failed to start
System.PublishingTools.GPServer:
LOCALHOST
Could not create object 'esriGeoprocessing.GPServer'.

My analyst claims the sample service, "SampleWorldCities", worked previously, that he could connect to it AND preview the Geography in ArcCatalog. Unfortunately, I'm not entirely convinced that is true ..so consider that a possible red herring.

However the sample server HAS always been visible, of that I am certain..

Meanwhile, I've been going through the motions of adding PostGRESql, and today my analyst says the sample service is unavailable to him.

I suggested we try publishing a new service with a shapefile as an experiment, but ArcServer fails immediately. Anyway it seems System > PublishingTools is stopped and will not start.

Things I've tried:

  • stopping/restarting ArcGIS Server, e.g. service arcgisserver [stop|start]
  • rebooting the system entirely, e.g. reboot
  • logs have been vague and no help ..particularly when googling errors with "CentOS" among my search terms
  • stopping iptables entirely, just in case the documentation misled me and I needed to open additional ports, e.g.
    service iptables stop
    service ip6tables stop
  • double-checking the ArcServer Manager > System > PublishingTools > Edit Service > Pooling:
    ..curiously, maximum instances shows 0 in the dashboard, even though minimum instances is set to 1 and maximum instances is set to 2. I tried changing the max to 3, saving, then restarting it, and it remained at 0 in the dashboard. I thought this was odd ..but perhaps residual of it failing to start in the first place.
  • double-checking ArcServer Manager > System > PublishingTools > Edit Service Security:
    Like iptables, I tried to side-step issues here by setting this to Public, available to everyone, then restarting it. Same.

Have I overlooked an obvious requirement necessary to enabling the PublishingTools.GPServer service? Alternatively, is there another troubleshooting step I might try to dig a little deeper?

  • I've had services stop and immediately fail to start due to the license expiring on the server. The logs in Server Manager were surprisingly helpful, but I think the log level had to be adjusted in the log settings to see the error. It might help to paste any errors you are getting in your question. – Mintx Jun 15 '16 at 21:44
  • Sometimes a service gets corrupted. Sometimes a security patch changes a required library in a certain way. Technically, CentOS is not supported, or it's only supported if the issue can be reproduced on RedHat. I've had to move projects off CentOS 6 to RedHat 6 because of compatibility issues. I suggest you uninstall Server and reinstall. If the problem persists, contact Tech Support. – Vince Jun 16 '16 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.