I use an ODBC connection to an ArcSDE table to return a current list of features for reporting purposes. The connection is pointed at a Microsoft SQL ArcSDE server and the connection info matches what I see in ArcCatalog.

The problem is that the ODBC connection returns a version of the table that is several months old - it shows some features that have been removed and doesn't show some new features.

Using the same connection information in ArcMap, I see a current version of the table and the current set of features.

I have created a new ODBC connection, tried refreshing the connection, and tried using the connection in Microsoft Access and R.

Any suggestions?

This question referred to a versioned table. As it turns out, an editor had checked out a parent version of the ArcSDE some time ago and never checked it back in. This was preventing subsequent child versions from being compressed back to the DEFAULT table. Child edits were being kept in a delta table but still showing in ArcMap; the ODBC connection wasn't aware of the delta table and was showing DEFAULT as it existed when the rogue parent version was checked out.


1 Answer 1


More than likely you are viewing the default version with odbc and an edit version through arc. Try reconcile version through arcgis tools.

  • this is a versioned table, so I will check the viewed table and request a compress to DEFAULT
    – user5797
    Feb 8, 2012 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.