1

Recently I've obtained the Water Utility Network Tool developed by ESRI. (Found here: http://solutions.arcgis.com/utilities/water/help/network-editing/ )

In working with it, I've attempted to visualize jump overs/unders when a water main crosses over another without intersecting. Which this tool does exactly as stated, except the actual visualization of the jump is tiny and when zoomed out beyond say 1:15, you cannot see it anymore, yet for purposes of my edits, I would like to see it on the map visually in a smaller scale setting. (For sizing representation, the map will show a multi-city block area per map, whereas the current jump radius is only visible at the sub block level).

I have found the configuration.xml files within the tool via 7zip archive. The first file Config.xml at the start appears to only handle how the button looks and where to find the image but not control the radius. I then found the second file under the 'install' folder called loaded.water.config which has this line of code within it

<!--The radius of the semi circle created by the Jumper tools-->
<add key="CreateJumps_Distance" value="0.5" />

This is the default setting. I've tested changing the value to 2.0 and even up to 5.0 and then saving the file and having the archive update.

Problem is, nothing changes in ArcMap Desktop then, it remains as if .5 is in effect that the radius didn't change. I attempted to re-add the add-in after the archive update but states that its an invalid digital signature now and won't install saying "Installation Failed. Access is Denied. The specified add-in may be in use." even though I've closed the 7zip and ArcMap.

Am I not updating the proper area to make the radius of the jump circle larger? Missing a step on updating this code to work?

3

Try editing the file once installed on your system. You are getting the error noted above because you have changed the file as recorded in the digital signature which violates the signature. Once installed the file should be located at "C:\Users\username\AppData\Roaming\ArcGISSolutions\ConfigFiles\loaded.water.config". The AppData folder may be hidden and you will need to check the Hidden items checkbox on the view ribbon in explore or manually type the path. I tested changing the value on my system and it works.

Found the following information later -

Information for configuring the Water Utility Construction Tools config files can be found at: ESRI - Water Utility Network Editing and Analysis, Configure Construction tools. I also found the source code for the tools at GitHub - local-government-desktop-addins.

  • Thank you very much! I had been under the C:\Users\username\Documents instead of AppData. To be honest, I'd kind have given up on this and was manually doing the jump by positioning the vertices, which wasn't very pretty as they weren't half circles but lumpy...things. – twweepie Jul 1 '16 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.