1

I would like to introduce some functions derived from scipyin my code. Since I also need arcpy, I use the Interpreter installed inside ArcGIS, whose directory is: (C:\Python27\ArcGIS10.3\python.exe).

My issue is that, if I try to install scipy from pycharm, I get this error:

numpy.distutils.system_info.NotFoundError: no lapack/blas resources found

and they suggest me to try again to install using the prompt command. But if I execute:

pip install scipy

I get the error:

'pip' is not recognized as an internal or external command, operable program or batch file.

I am not sure if the issue is related to the fact my interpreter is the ArcGIS one, but if yes, how can I solve the problem? Otherwise, what may the reason be?

3

The Python installation of ArcGIS is not "standard"

1) you need first to install pip
2) then in theory you can install SciPy but

In fact, it will break the ArcGIS installation (including Python))

ArcGIS 10.4 will be shipped with SciPy already integrated, see SciPy Integration in ArcGIS)

  • 1
    I've always found this as a great resource for compiled (installable) python modules - lfd.uci.edu/~gohlke/pythonlibs/#scipy – KHibma Jun 22 '16 at 17:46
  • 2
    unfortunately, due to 'reasons', scipy didn't make it into the 10.3.1 release. It is included in the 10.4 release. – KHibma Jun 22 '16 at 20:03
  • Understood. I will try to install the new version of ArcGIS – Patapunfate Jun 23 '16 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.