1

Whenever I try to load the Google Hybrid layer on QGIS 1.8.0 and 2.0.1, I get this error:

This page was unable to display a Google Maps element. Please contact the site administrator. If you are the administrator of this site, please check the JavaScript console or check the following page for troubleshooting: http://g.co/mapsJSApiErrors

How do I correct the error so that the map can load?

2
  • OpenLayers Plugin: Printing and rotating of Javascript API based layers is currently not supported! this is my problem. what can i do ?
    – Cristiano
    Jan 10, 2019 at 20:38
  • Welcome to GIS SE! As a new user, please take the short tour. This is a little different than other sites - it's a focused Q&A site, not a discussion forum. Please do not use answers to ask additional questions.
    – Andy
    Jan 10, 2019 at 20:43

3 Answers 3

4

I got a key from google and included in each of the GOOGLE html files in the openlayers plugin html directory... and it started working again.

add your key to the line https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY

Also have to take out the v=3.3 (version) in the current html code.

3

I don't know why that's happening, there seems to be a few posts asking about that.

This post "Why are the Google basemaps no longer appearing in QGIS?" has a good solution which allows you to add the Google Tile server as a layer. Uncomment the line for which basemap you want to use and add the file as if it were a Raster layer.

Other suggestions have been to use the QuickMapServices plugin as an alternative.

Other related posts i've seen on SE: Google Maps not Showing in QGIS 2.12

0
1

Apparently Google has changed the Javascript API to require a key and includes a quota for access This began June 22, 2016. https://developers.google.com/maps/pricing-and-plans/standard-plan-2016-update So this has created an issue for the plugin, I think. You can debug the error by opening up the Google html files in ./qgis2/python/plugins/openlayers_plugin/html in your browser and looking in the browser console (in Firefox)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.