0

I have the following problem:

enter image description here

The edge of the imagemosaic is not fit well, Im using geoserver imagemosaic tool to serving orthophotos through wms server. Is it a CRS, Bounding Box problem?

3

In the imagemosaic setting (in the layer page), try setting "output transparent color" to black

  • How can I do it with a single GeoTiff? It has only input transparent color option.. @andrea-aime – Balazs Jun 24 '16 at 18:01
  • Simple, you cannot, you have to use a mosaic (it can be used for a single file too, clumsy I agree, but it's probably the easiest solution). – Andrea Aime Jun 25 '16 at 10:02
  • thanks for this, it solved my problem which was having black spaces between the tiles instead of transparency – Luffydude Nov 3 '16 at 17:19
2

Does the data get reprojected? Typically when I reproject raster to a different coordinate system I get black edges like that, because the raster file itself is rectangular, but the area covered by the reprojected data isn't. The black parts are areas of 'nodata'. If it's an issue of the look of the thing, perhaps you can make nodata transparent or white?

  • Thanks Mark, Everything fine, How can I rid of nodata? Is it settings in geoserver? – Balazs Jun 23 '16 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.