I have a dynamic text element I've edited to show open and closed store locations: screenshot of dynamic text

I cannot seem to remove the spaces between my text. Note: the line you see before the last "0" is my legend border. The proper display should look like (not bold): 2014: 3/1 2015: 0/1 2016: 0/0

Here is my current text properties:

2014:<dyn type="page" property="attribute" field="StoreB_Cls2014" domainlookup="true"/>/<dyn type="page" property="attribute" field="StoreA_Cls2014" domainlookup="true"/>2015:<dyn type="page" property="attribute" field="StoreB_Cls2015" domainlookup="true"/>/<dyn type="page" property="attribute" field="StoreA_Cls2015" domainlookup="true"/>2016:<dyn type="page" property="attribute" field="StoreB_Cls2016" domainlookup="true"/>/<dyn type="page" property="attribute" field="StoreA_Cls2016" domainlookup="true"/>

The attributes are Double format.

  • What is the text box text-align properties set to?
    – Midavalo
    Jun 24, 2016 at 4:18
  • 1
    Happening all the time. I usually calculate label field to pull them all together
    – FelixIP
    Jun 24, 2016 at 4:58
  • The alignment did not make a difference whether I set it to left or right. It defaults to right. Same as the anchor setting. Seems like a bug.
    – ripsin
    Jun 24, 2016 at 13:44

1 Answer 1


The trick is to change the text alignment in the attribute table!

All you have to do is: 1. Open the attribute table and right click on the field heading 2. Click Properties 3. In the Field Properties dialog box, click the [...] box next to Number Format: Numeric 4. In the Number Format dialog box, chose the Left Alignment radio button.

This is also where you can make labels or dynamic text display thousands separators, pad with zeros, or round numbers. Another way would be to add a new text field to the attribute table and use the field calculator to populate using the old numeric field.Before


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.