2

I tried to test the QGIS Offline Editing Plugin but it appears not to work at all.

I'm using qgis 2.14.3 running on a Lenovo Yoga 900 and Windows 10 on the client side. For the server I'm running Ubuntu 16.04 Postgresql 9.5 and PostGIS 2.2 on the same machine using Virtualbox 5.

The workflow: import a shapefile into PostGIS using QGIS desktop>DBManager. After loading the layer I Click the 'toggle editing' button and select a feature so that it is highlighted yellow. I then click the 'node tool' button, select a node and move it to a random spot. At this point, I do not save the change as I just want to ensure editing works for PostGIS. Editing seems to behave as expected for PostGIS layer.

I then select the layer in the 'Layers Panel', click the 'Database' menu item and select 'Offline editing>Convert to offline project'. A .sqlite file is created on my local drive and the Layer has '(offline)' appended to its title in the 'Layers Panel'.

Editing (Offline): I attempted to follow the workflow above however, when I select a feature another random feature is selected (highlighted yellow)! If I pan then others features are highlighted yellow as if panning changes the feature selected!! If I click the 'Node Tool' and try to select a node on the highlighted feature then no nodes are selected (stay as crosses and not cross and box) and the edit tools seems to stop working totally unless I reload the project file.

I have tried this on three separate layers including 2 polygon and one line. The behaviour is the same for all three layers.

I checked 'Log Messages Panel' under the 'Processing' tab I have this warning "OTB was not found or is not correctly installed." I'm not sure if the Offline Plugin uses Orfeo Toolbox??

I also found this post that seems very similar but there doesn't seem to a resolution: Alternatives to Offline Editing Plugin of QGIS?

  • I tried to load just the .sqlite layer into a different qgis project to see if I can edit it. It appears to be OK (i.e. I can select a polygon and move one of its nodes ok). – Colin Jun 27 '16 at 8:38
  • I did some further testing today. I've tried various data types and like the linked question, I believe the tool simply doesn't work. I have been able to replicate my problem consistently. I can edit the sqlite layer successfully so it seems not to be an sqlite issue. The only conclusion I can draw is that the project once converted an offline project is totally broken. I don't have another environment available so it would be good if someone could see if it is my environment that is the issue (Win10/qgis2.14.3/postgis2.2)? – Colin Jun 28 '16 at 5:19
  • Thanks for finding this, there is a call for testing from the QGIS devs but it's for 2.16 because that's where all the updates are being made. Please see osgeo-org.1560.x6.nabble.com/… and consider joining in the testing if possible. These would be great to have fixed! – SaultDon Jun 28 '16 at 17:43
  • Thanks SaultDon. I followed up the link. I installed the nightly build (2.15.0-26) and was able to move a polygon node and change one of its attributes. Not extensive testing but it looks like this should work in 2.16. – Colin Jun 29 '16 at 0:06
0

Unfortunately, it appears the Offline Tool is not working correctly in version 2.14.3 however, I did a very basic test of the nightly build 2.15.0-26 and the tool performed as expected. I am hopeful that the tool will be functional in 2.16.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.