1

When I georeference satellite images with a CRS for my region (Hartebeeshoek94), I get a scale of 1:10 and larger. But when I use WGS84 the scale appears correct, e.g. 1:50 000.

I am using QGIS v2.13.3. For the Transformation settings, I use Thin Plate Spline for Transformation Type, Linear for Resampling Method and Hartebeeshoek94 for the Target SRS.

What I am doing wrong?

  • 1
    Did you check the "on the fly" projection while setting up your project's SRID? This could explain some of the scale issues while visualizing your data if your projection actually worked. – Moreau Colin Jun 27 '16 at 13:43
  • I have tried running the georeferencer with and without "on the fly", but it makes no difference to the scale. – Douw Jun 27 '16 at 14:18
  • How do you enter the coordinates for the GCP points? If you use latlong degrees, the CRS MUST be set to WGS84. If you use From map canvas, the target CRS must be the same as the canvas setting. – AndreJ Jun 28 '16 at 6:10
  • I now used WGS84 as the CRS, but when I save the layer as a Hartebeeshoek94, it moves the images and display it upside down. How can I georeference in WGS84 and then set the layer CRS without the layer displaying so wildly incorrect? – Douw Jun 28 '16 at 8:55
  • Save As is not the right tool to reproject rasters, it only works with vectors. Use raster -> projection -> Warpinstead, to a new filename and different CRS. Does the freshly georeferenced image align with an Openstreetmap background from the QuickMapServices plugin, with otf enabled and project CRS set to EPSG:3857?? – AndreJ Jun 29 '16 at 11:56
1

My initial thought is that your project settings are not in the correct coordinate system, regardless of the layer settings.

I would start a blank project and only import a single layer and that is already set at the Hartebeeshoek94 projection. I'm not sure if QGIS takes the projection of the first layer, so maybe right click the layer and choose 'Set Project CRS from Layer.' At that point you can visually check the scale to make sure things look right before you start to georeference. Then start your georeferencing over from scratch.

  • Thank you for the suggestion. I did try it but the scale still appears correct. I found that the coordinates appear to be correct but the scale is wrong, e.g. the line measures in mm what should be hundreds of meters. – Douw Jun 28 '16 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.