I am having issues updating a feature service with Safe FME. I looked up the example model and as far as I can tell I am following it. It seems to be running most of the model and throws an error as it starts trying to update the Feature Service. I am not sure what the issue is. I set the Feature Layer to allow edits. I have the reader for the ArcGIS Feature Layer and the Reader for the shapefile source, also the FeatureMerger to add the FID Field to the update table. LOG: http://pastebin.com/U1Hu06GS

enter image description here

  • Line 47 of your error shows: Python Exception <HTTPError>: 404 Client Error: Not Found. Do you have any python code running? Perhaps as a python parameter or shutdown script? If so, can you please edit your post to show it?
    – Fezter
    Jun 28, 2016 at 22:36
  • I do not have any Python running, I am guessing it is something on ArcGIS onlines processes. That is what I'm trying to figure out.
    – GravitaZ
    Jun 29, 2016 at 3:08

3 Answers 3


I have figured out what the issue was. I had to add the ArcGIS Online Reader for the existing Feature Layer before adding the ArcGIS Online writer. Then I had to copy the "Layer Definition" from the previously added ArcGIS Online reader for that Feature Layer. Then it worked as expected. enter image description here


I was running into similar situation attempting to write to AGOL hosted tables. Was getting error 403 (You do not have permissions to access this resource or perform this operation). I tried about every permutation of connection configuration I could think of, but no love. However, when I added a Reader to the AGOL feature service, it started working, even though Reader is not really involved in workflow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.