6

I used the zonal statistics as table tool in ArcGIS10.4 to calculate SRTM, the in_zone is a gridded shapefile, the in_value_Raster is the SRTM extracted for the region as in the image (90m x90m). The result table gave me min values of 1 and 0, which does not match the input raster at all. I would like to know what might be causing this problem and how to solve it. Ignore NoData option was checked. Both input shapefile and raster have the same spatial reference system:WGS84. I also converted them into UTM but the min value still didnt make any sense. input zone layer (grids) and input raster layer output table, inputs referenced with WGS84 output table, inputs referenced with UTM complete stats

7
  • It may have to do with the number of unique values in your raster and/or the range of values in your raster. There are some limitations that ESRI should make more explicit. There's not much or clear documentation on the limitations, but see: pro.arcgis.com/en/pro-app/tool-reference/… and pro.arcgis.com/en/pro-app/tool-reference/…. So, you may be getting an artificial wrap-around of values.
    – Tom
    Commented Jun 29, 2016 at 16:14
  • there is a bug shifting the column, your 0 and 1 are the area (in degree, rounded) and the very large values are your areas in meters. I mentioned it in another answer, but I don't remember which was the exact question. Anyway, read your table by replacing count with ID, area with count, min with max ... and you'll get the consistent values.
    – radouxju
    Commented Jun 29, 2016 at 16:33
  • Thank you Tom, I reset the limit for raster under options.
    – Mouse
    Commented Jun 29, 2016 at 17:40
  • @radouxju, could you maybe describe how exactly the columns are shifted? My statistic selection was 'ALL', please see the last image. If I shift all the columns to the next column my MEDIAN column would not have any rows to match, thank you.
    – Mouse
    Commented Jun 29, 2016 at 17:41
  • Indeed you loose the last column. If you need the median you need to specifically ask for it.
    – radouxju
    Commented Jun 30, 2016 at 7:04

3 Answers 3

2

I did some testing and it appears that when you use your 'OBJECTID' as your zonal field, it cant add it as a column in the output so it causes a miss-match between the columns and the headers (column names). The workaround is to use a different column as your zonal field in your input and your columns should line up in your output.

1

This is a bug, let's hope that it will solved soon because you loose the median column. The Feature ID header is missing then all column header are shifhted one step left.

enter image description here

2
  • re: 'This is a bug'. By a bug, do you mean document as a bug by esri? If so, is there a bug number to track when it has been resolved?
    – Rex
    Commented Apr 12, 2018 at 19:53
  • @Rex there is no bug report as far as I know. I call it a bug because the tool does not work as expected, and it work properly in previous versions.
    – radouxju
    Commented Apr 13, 2018 at 6:47
1

I ran the zonal statistics as table again with all the setting identical to the previous try on arcGIS 10.3x and got the correct output with all the desired columns (Image as below).

new output column using arcGIS 10.3x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.