2

I've been trying to use a dataset for the Time-Aware app on AGOL, but instead of using the year of a data point's collection, I'm trying to use the sequential order number (integer 1-10) of each layer. I've set the Time Field to the correct field when enabling time in ArcMap (10.3), but my integer range is between 1 and 10, and I noticed that the Field Format I have selected is "YYYY" (implying that four consecutive integers may be necessary to fulfill the format's requirement?). When I try this, share the whole set of features to AGOL, and attempt to view the layer in the Time Aware app, it does not show. It has only shown for layers for which I set the Time Field to the 4-digit year.

Is there anything else I can try in order to use the order number of each layer as the Time Field, and have the layer show up in the Time Aware app (in sequence)?

1

When setting the Time properties in ArcMap, it seems that the only options are YYYY, YYYYMM, YYYYMMDD and YYYYMMDDhhmmss:

enter image description here

ArcGIS Online probably requires the same time format, so the best workaround is probably to set the years as 2000, 2001 -> 2010 etc.

  • Yes the format is probably the same, but I was trying to set a number that was less than 4 digits as the Time Field. I'm guessing that, because the Field Format specifies 4 digits, the number is only recognized by ArcGIS Online if the data is formatted according to that specification. So, the only other workaround I can think of is setting the cycle numbers to 0001, 0002, etc. but I don't want to do that. I'll think of another way to use the year data. Thanks! – pierrethepear Jul 1 '16 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.