I'm new to ArcGIS 10 and am trying to do a really simple field calculator equation and it is not working. I'm just trying to find the percentage of a certain demographic trait by doing:


It is populating about 10% of the column correctly and then I get an error:

There was a failure during processing, check the Geoprocessing Results window for details

Obviously my syntax is not incorrect or else it wouldn't start populating the field correctly.

Does anyone have any idea why this is happening?

5 Answers 5


You probably have a divide-by-zero error. Field Calculator definitely cannot divide when zero is the denominator, and sometimes will even throw errors with zero as the numerator. To get around this, click the "Select by attributes" button in the Attribute Table (top left corner, third from the left). Then type in this formula:

"Asian" <> 0 AND "Total" <> 0

This will select only records with no zeroes. When you use field calculator, it will only process these records. You can play around with other selections to get it right.

  • There won't be a problem with zero values for [asian], so why reference this field in the query? In fact, a record with nonzero values of [asian] and a zero value of [total] will still cause a problem.
    – whuber
    Feb 25, 2012 at 18:55

It might help to know what the results says is wrong
to see what the gpresults are go to...
geoprocessing> results



As was the case for user "I am a guest", I got the same error and my issue was with decimal notation. I am using an American computer but studying in Spain where they use commas instead of periods to denote decimals, i.e. instead of $2.00 they write $2,00.

I changed my computer's default formatting settings to match the format of the data in the Region and Language section of the control panel. After that the calculation worked correctly. I am not happy with this solution but do not want to edit the data either.


I had a similar problem and it turned out to be a problem of decimal notation. for some reason my results are displayed with a ',' as a decimal seperator but the field calculator interprets this as a seperator for thousands. When copying the values and changing ',' with '.' i got the correct results.


I was having the same problem, and it turned out to be a syntax error. I think it's pretty lame that there's no longer a pop-up to notify you of this in 10, you have to go to Geoprocessing > Results, as Brad Nesom indicated above. The fact that the pop-up didn't appear led me to believe my syntax was ok and look for a different problem.

  • 3
    A syntax error, by its very nature, will fail on the first record: you can't get 10% of the way through and then fail (unless the table is so small that 10% is the first record).
    – whuber
    Feb 25, 2012 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.