2

I'm having trouble clipping a shapefile in QGIS so I'll take you through my steps.

I've downloaded the land shapefile here http://www.naturalearthdata.com/downloads/10m-physical-vectors/

When I load it in QGIS I right click on the layer and save as EPSG 3357 UTM Zone 17N.

Then I click to allow on the fly projection so I can see my newly projected layer.

I load in the coordinates (600967.4, 2177300) about which I make a buffer of 15km.

Then I clip the map with this 15 km circle but this doesn't appear on the map nor can I see it if I load it into QGIS.

It seems like I'm missing something with the projections.

1

The weak point seems to be at the single point. If you import it with Add delimited text, it is only a temporal layer, and has no CRS information written to disk. However, the clipping tool does not look into QGIS layer settings, only what CRS information is written on disk. So you better save the point to a shapefile with EPSG:3357, then proceed with the buffer.

You can check the object count of the result. If it is zero, the clipping failed. Check the .prj file of all layers to see if they are correctly set. By default, they can be set to WGS84, which places the geometry into nowhere.

|improve this answer|||||
  • That is how I'm adding the point data, I tried what you suggested but got nothing. I've noticed that if I save the map with 3357, quit out of QGIS and try to load it back in, it won't display. – adkane Jul 8 '16 at 16:13
  • UTM projection is not useful for a worldwide map. I clipped it to the UTM 17N zone boundary before working on. Maybe it is better to create the buffer in UTM, then reproject it to WGS84 and clip with the original NE dataset. – AndreJ Jul 8 '16 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.