7

I installed twice Qgis 2.16 using OSGeo 4w install. First I uninstalled all the previuos version and installed 2.16. Everything worked fine but when I open Qgis I have a warning message:

Couldn't load QGIS utils.
Python support will be disabled.


Traceback (most recent call last):
  File "", line 1, in 
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 20, in 
    from future import standard_library
ImportError: No module named future


Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version:
2.16.0-Nødebo 'Nødebo', d0b3e39

Python path:
['C:/OSGEO4~1/apps/qgis/./python', u'C:/Users/Gerardo/.qgis2/python', u'C:/Users/Gerardo/.qgis2/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\\OSGEO4~1\\bin\\python27.zip', 'C:\\OSGEO4~1\\apps\\Python27\\DLLs', 'C:\\OSGEO4~1\\apps\\Python27\\lib', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\plat-win', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\lib-tk', 'C:\\OSGEO4~1\\bin', 'C:\\OSGEO4~1\\apps\\Python27', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\PIL', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\pytz-2012j-py2.7.egg', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode']

I uninstalled and installed again but I get the same error. Qgis starts but I have nothing python related as expected. I know about this

Couldn't load QGIS utils; Python support disabled; No module named future

and also this

https://hub.qgis.org/issues/14577

The problem is the same even though the last link states the issue is closed.

Any ideas on how to solve the problem? some solutions on the first link do not apply to a win system

  • Perhaps it might help to wait for the official release of QGIS 2.16.0. I had no problems so far on Ubuntu Xenial and Linux Mint with it. OSGEO4W64 runs too, but the TileLayer plugin does not work anymore. Seems to be another issue. – AndreJ Jul 11 '16 at 16:15
  • BTW `C:\OSGeo4W64\apps\Python27\Lib\site-packages\future\standard_library` exists on my system. – AndreJ Jul 11 '16 at 16:23
  • Not in mine...seems that I have to wait for the official release – Gerardo Jimenez Jul 11 '16 at 16:50
  • You can look into C:\OSGeo4W64\var\log for any error messages concerning python-future, or create a ticket at hub.qgis.org. BTW I'm on Windows 8.1; not sure what Windows 10 has different. – AndreJ Jul 11 '16 at 17:08
  • The future folder was already present before I updated from qgis 2.15 to 2.16. Maybe you have to re-install python-future manually within osgeo4w setup. It is not in QGIS 2.14 standalone. – AndreJ Jul 11 '16 at 17:23
1

I can not reproduce your error, maybe the installer has been fixed by now.

Similar to the linked question, which deals with Linux installations, you can run the OSGeo4W installer again, and choose Advanced installation to re-install the python-future package.

This might not help with the standalone installer, but copying missing folders from OSGEO4W to standalone should work.


UPDATE

The standalone installer from today has the needed future folder too, so you can copy that to the OSGeo4W64 folder as well.

The bug already has a ticket and has been fixed: https://trac.osgeo.org/osgeo4w/ticket/514

1

This has been reported as a bug on QGIS (bug number 15279). The reporter says: "the problem is the use of the character "ø" (o-slash) in the directory name for the QGIS program directory: "C:\Program Files\QGIS Nødebo". If you make a name change of the installation directory to ex. "C:\Program Files\QGIS Noedebo" it works without a hitch." I tried this by re-installing 2.16, with the directory name changed C:...to Noebedo..and 2.16 now works perfectly, including loading Python correctly.

  • Gerardo did not use the standalone, it was not published yet. You see in the errorlog that he installed into OSGeo4W64. Your issue is yet another bug. – AndreJ Jul 15 '16 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.