2

I have problem again almost like version QGIS 2.14. I did not solve the problem. QGIS 2.14 GRASS geoalgorithms don't work?

I install C:\MinGW and now QGIS grass geoalgorithms don't work? There is 300 geoalgorithms and I have only 148, what is the problem? Is there a solution?? PC Windows 10 x64.

enter image description here

enter image description here enter image description here

I need other grass geoalgorithms like v.net and others

  • Is it that you are missing some algorithms? or that you can't run these 148 you have? Can you attach an error msg? Personally, since I've upgraded beyond QGIS 2.8, all GRASS geo-algorithms stopped working, and I've started using GRASS GUI directly. – dof1985 Jul 17 '16 at 12:26
  • 1
  • Do I need to install OSGEO4W 64-bit, what is this, is this same like QGIS? – nagib Jul 17 '16 at 12:45
  • Yes OSGEO4W includes the same QGIS. I wonder why Grass 7 is asking for MSYS. That was cancelled 3 months ago. Do you have processing still as an external plugin? Only Grass commands (which is Grass 6) still needs Msys. – AndreJ Jul 17 '16 at 13:05
  • I do not have problem with proccesing with this 148 geo-algorithms but I need other geo-algorithms. I forgot, where I can find grass environment? Earlier version had some grass icons, now I cannot find it. – nagib Jul 17 '16 at 13:12
3

Using OSGeo4W64 setup might be the best solution for you. You have to select QGIS and GRASS (which is GRASS7).

Make sure you delete C:\users\<username>\.qgis2\python\plugins\processing if you still have that.

  • it's a little strange, on other PC with the same configuration it works fine. I will try, thanks – nagib Jul 17 '16 at 13:15
  • On the other PC, do you have the Msys entry under Grass7 in the options menu? What version of processing is listed under Installed plugins? It should be 2.12.99. – AndreJ Jul 17 '16 at 13:16
  • No, I have path C:\MinGW,problem was the same – nagib Jul 17 '16 at 13:21
  • Thanks "AndeJ" and "If you do not know- just GIS", I delete C:\users\<username>\.qgis2\ and I install QGIS 2.16 again, now all works fine. This solve my problem. Only I lost all my plugins, I have to install again plugins – nagib Jul 17 '16 at 13:45
  • Same problem here. After installing my self written plugin (works fine with 2.14) all grass tools are not working. – Pimpel Jul 29 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.