0

I've been working on migrating our parcels to the parcel fabric with hopes of migrating to the LGIM. I imported several CAD files, cleaned a large test area, and validated the topology (0 errors). Everything gets loaded into the staging geodatabase that is provided by ESRI, and the only two feature datasets I'm working in are Type6LotUnits and Type7TaxParcels. Type6 and type7 data loads just fine within the staging area. Type6 data will load into fabric with no issues and display my lots as it should, but whenever I try to load type7 (the actual parcels) I get an error saying that the source feature class must contain features.

\USER\xxxx\Final Parcel

Fabric\Staging_Geodatabase.gdb\Type7_TaxParcels\Type7Parcels" # # "0.1 Meters"

UNJOINED_GROUP DEGREES_MINUTES_SECONDS QUADRANT_BEARING COMPUTE_AREA ACRES "0.5 Meters" 3_1908_TO_1980

Start Time: Thu Jul 14 16:17:50 2016

Verifying input topology dataset...

Validating input dataset coordinate system...

Importing topology.

Loading topology lines...

The source feature class must contain features. Failed to execute (LoadTopologyToParcelFabric).

Failed at Thu Jul 14 16:17:57 2016 (Elapsed Time: 6.85 seconds)

I'm literally stumped at this point. I've tried to load the data on different machines, locally vs. over the network. I've loaded and reloaded everything, including moving the data to new staging databases/fabrics. Nothing I do seems to work. Has anyone encountered this issue? If so, how was it fixed? As you can see, no error code is mentioned, and the internet seems to not yield anything for an answer.

1

I figured it out.

Using the staging database, type7arcs & type6arcs feature classes use the domain IrParcelLineCategory which has coded values 0, 1, 2, 3, 5, 6. Well, if you type this field as 7 (as it says you need to do), you will get the error noted above. It just happened to work fine with type6arcs because you type the field as 6, which is a coded value.

The remedy to this was to mimic the example in the TaxParcelEditing.mxd you download. The staging data uses the domains IrParcelLineCategory (for polylines) and IrParcelType (for polygons). Match your data to those domains. If you don't end up using a type7 field for those feature classes, just make an empty type field and calculate it with 7.

In addition, the domains do not show up when you add new fields unless your source data is in the same geodatabase as your staging data.

0

I understand your topology is valid, but have you tried a check geometry on those parcels? I ran into several parcels which wouldn't load due to complex geometry. I wound up having to explode multi-part and import each of those separately.

  • Running the geometry check comes up clean, but I did find a few lines that are multi-part (300 out of 24.2k) using the curves and line tool to select those lines. I will explode them and try again. I'll report back! – shoman24v Jul 18 '16 at 20:11
  • Well, no luck still. Removed all the lines that were multi-segment, re-validated the topology, and still am getting the same error. – shoman24v Jul 18 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.