I have a layer I need to symbolise with graduated colours based on one field and graduated symbols based on another field.

Sizes are based on a field that stores a count (range 1 to 50). Colours are based on a field that stores cost (range 0 to 7500).

I set up Symbology by selecting Multiple Attributes, choosing my Count field and manually setting the sizes, then selecting Variation by Colour Ramp and choosing my Cost field for the ramp.

It has mostly worked, except it's not using quite the same colour ramp as I selected. The two highest values are using the same colour, and I can't find a way to update it.

Symbology > Multiple Attributes:
enter image description here

Colour Ramp:
enter image description here

End result (note the high values are still yellow, not red):
enter image description here

The largest point on the map in my screenshot above should be coloured red, as the value for this point is over $4000.

Has anyone had success in setting symbology this way? What do I need to do/change to get this to work?

  • Can´t reproduce it with 10.2 here, color and size are working (but i always have to set the color ramp on the first level new for refreshing). You could try to set the option to use feature values for class breaks. Otherwise i think its a bug.
    – Matte
    Commented Jul 19, 2016 at 5:26
  • @Matte I'm not sure what you mean when you say you "always have to set the color ramp on the first level new for refreshing"? Do you mean I should try setting the colour ramp first (in the first screenshot) and then Variation by size? This wouldn't work for me as there are way too many different values in Cost
    – Midavalo
    Commented Jul 19, 2016 at 6:37
  • It is not taking the values i defined at "color ramp" until i choose one of the color ramps under "color scheme" again. When trying to find a good color ramp it is a bit annoying to have those extra clicks.
    – Matte
    Commented Jul 19, 2016 at 7:26

1 Answer 1


This is a bug. It is using the color ramp, but only a small portion of it. It doesn't matter how you change the settings, you're not going to get the full color ramp for your points. You will only get a small section of the color ramp. You may be able to improve the color range by increasing the number of classes, changing the class break values, or adjusting the range. Please post a comment if any of those tests work for you.

  • Thanks. Do you have more info about the bug? Maybe a link to the esri bug page ?
    – Midavalo
    Commented Jul 19, 2016 at 7:39
  • 1
    Found what looks to be the bug - NIM085881
    – Midavalo
    Commented Jul 21, 2016 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.